1011 World Cup Betting (20)(20 分)

 

题目: 

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

Sample Output

T T W 37.98

分析:

题目本身很简单,需要分析的是我的英语阅读水平为什么这么烂QAQ

这里补上题目翻译:(谷歌翻译,有的地方不是特别准但比我自己翻的好多了,至少大概能看懂题意……)

随着2010年FIFA世界杯的举办,世界各地的足球迷越来越兴奋,成为最佳球队在南非争夺世界杯奖杯的最佳球员。同样,足球博彩迷通过各种世界杯投注将他们的钱放在嘴边。

中国足球彩票提供了“三赢”游戏。获胜的规则很简单:首先选择任意三场比赛。然后对于每个选定的游戏,下注三个可能的结果之一 - 即W代表胜利,T代表领带,L代表失败。每个结果都有一个奇怪的分配。获胜者的奇数将是三次赔率65%的乘积。

例如,3场比赛的赔率如下:

 W T L
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1

要获得最大利润,必须购买第3场比赛的W,第2场比赛的T和第1场比赛的T.如果每次下注2元,则最大利润为(4.1 * 3.0 * 2.5 * 65%-1)* 2 = 37.98元(精确到2位小数)。

输入

每个输入文件包含一个测试用例。每个案例包含3场比赛的投注信息。每个游戏占据一条线,其中三个不同的赔率对应于W,T和L.

输出

对于每个测试用例,在一行中打印每个游戏的最佳赌注,最大利润精确到小数点后2位。字符和数字必须用一个空格分隔。

反思:

1、对于double和float,实际存储的数和你输入的数可能并不相同,不信拿这个题的范例调试看看?原因:二进制浮点数储存,做不到精确表示,涉及到计算机组成原理的知识。

2、setprecision会自动四舍五入

代码:

#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
	double x, y, z, answer = 1;
	string result = "WTL";
	for (int i = 0; i < 3; i++)
	{
		cin >> x >> y >> z;
		if (x > y&&x > z) { cout << result[0] << ' '; answer *= x; }
		else if (y > x&&y > z) { cout << result[1] << ' '; answer *= y; }
		else { cout << result[2] << ' '; answer *= z; }
	}
	cout << fixed << setprecision(2) << (answer* 0.65 - 1) * 2;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值