PAT甲级查找元素1011 World Cup Betting

昨天看了一本书,《你的灯亮着吗》,用一些小例子讲述各种情况下问题解决者面对问题做出的反应,很薄,不到两个小时就看完了, 会反复读。里面有一句话:当你以为你认为问题很好地解决了,其实并没有。正如下面这道题很简单,但显然有更简单的方法。

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

 

#include<bits/stdc++.h>
using namespace std;
int main(){
    char res[3];
    double odd=1,a,b,c,d;
    for(int i=0;i<3;i++){
        scanf("%lf %lf %lf",&a,&b,&c);
        d = max(a,b);
        d = max(d,c);
        if(a-d==0)res[i]='W';
        else if(b-d==0)res[i]='T';
        else if(c-d==0)res[i]='L';
        odd *=d;
    }
    odd = (odd*0.65-1)*2.0;
    for(int i=0;i<3;i++){
            cout<<res[i]<<" ";
    }
    printf("%.2lf",odd);
}

可以改进: 

#include<bits/stdc++.h>
using namespace std;
int main(){
    char res[3];
    double odd=1,a,b,c,d;
    for(int i=0;i<3;i++){
        scanf("%lf %lf %lf",&a,&b,&c);
        d = max(a,b);
        d = max(d,c);
        if(a-d==0)cout<<"W ";
        else if(b-d==0)cout<<"T ";
        else if(c-d==0)cout<<"L ";
        odd *=d;
    }
    odd = (odd*0.65-1)*2.0;
    printf("%.2lf",odd);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值