HDU 5806 NanoApe Loves Sequence Ⅱ

Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!

In math class, NanoApe picked up sequences once again. He wrote down a sequence with n numbers and a number m on the paper.

Now he wants to know the number of continous subsequences of the sequence in such a manner that the k-th largest number in the subsequence is no less than m.

Note : The length of the subsequence must be no less than k.
 

 

Input
The first line of the input contains an integer T, denoting the number of test cases.

In each test case, the first line of the input contains three integers n,m,k.

The second line of the input contains n integers A1,A2,...,An, denoting the elements of the sequence.

1T10, 2n200000, 1kn/2, 1m,Ai109
 

 

Output
For each test case, print a line with one integer, denoting the answer.
 

 

Sample Input
1 7 4 2 4 2 7 7 6 5 1
 

 

Sample Output
18

给一个序列,求 第K大的数大于等于m的区间 的个数是多少?

尺取法  

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#include <stack>
#include <string>
#include <map>
#include <set>
#define pi acos(-1)
#define LL long long
#define ULL unsigned long long
#define inf 0x3f3f3f3f
#define INF 1e18
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef pair<int, int> P;
const int maxn = 5e5 + 5;

LL a[maxn];
int main(void)
{
//	freopen("C:\\Users\\wave\\Desktop\\NULL.exe\\NULL\\in.txt","r", stdin);
    LL T, i, j, n, m, k, cur, ans, cnt;
    scanf("%I64d", &T);
    while (T--)
    {
        scanf("%I64d %I64d %I64d", &n, &m, &k);
        for (i = 1; i <= n; i++)
            scanf("%I64d", &a[i]);
        cur = 1;
        ans = cnt = 0;
        for (i = 1; i <= n; i++){
            if (a[i] >= m)
                cnt++;
            if (cnt >= k){
                while (cnt >= k){
                    ans += n - i + 1;
                    if (a[cur] >= m)
                        cnt--;
                    cur++;
                }
            }
        }
        printf("%I64d\n", ans);
    }
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值