数据结构实验之链表二:逆序建立链表
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。
Input
第一行输入整数N;;
第二行依次输入N个整数,逆序建立单链表。
第二行依次输入N个整数,逆序建立单链表。
Output
依次输出单链表所存放的数据。
Example Input
10 11 3 5 27 9 12 43 16 84 22
Example Output
22 84 16 43 12 9 27 5 3 11
Hint
不能使用数组!
代码如下:
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
struct node *creat(int n)
{
int i;
struct node *head,*p;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
for(i=0; i<n; i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=head->next;
head->next=p;
}
return head;
};
void Show(struct node *head,int n)
{
struct node *p;
p=head->next;
while(p)
{
printf("%d ",p->data);
p=p->next;
}
}
void main()
{
int n;
struct node *head;
scanf("%d",&n);
head=creat(n);
Show(head,n);
}