数据结构实验之二叉树的建立与遍历

数据结构实验之二叉树的建立与遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

Input
 输入一个长度小于50个字符的字符串。
Output
输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
Example Input
abc,,de,g,,f,,,
Example Output
cbegdfa
cgefdba
3
5
Hint

代码如下:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
    int data;
    struct node *left;
    struct node *right;
};
char s[51];
int n;
struct node *creat()
{
    struct node *tree;
    if(s[++n]==',')
        tree=NULL;
    else
    {
        tree=(struct node *)malloc(sizeof(struct node));
        tree->data=s[n];
        tree->left=creat();
        tree->right=creat();
    }
    return tree;
};
void mid(struct node *tree)
{
    if(tree)
    {
        mid(tree->left);
        printf("%c",tree->data);
        mid(tree->right);
    }
}
void behind(struct node *tree)
{
    if(tree)
    {
        behind(tree->left);
        behind(tree->right);
        printf("%c",tree->data);
    }
}
int sum(struct node *tree)
{
    if(tree==NULL)
        return 0;
    if(tree->left==NULL&&tree->right==NULL)
        return 1;
    else
        return sum(tree->left)+sum(tree->right);
}
int high(struct node *tree)
{
    int hl,hr,max;
    if(tree)
    {
        hl=high(tree->left);
        hr=high(tree->right);
        if(hl>hr)
            max=hl;
        else
            max=hr;
        return (max+1);
    }
    else return 0;
}
int main()
{
    scanf("%s",s);
    n=-1;
    struct node *tree;
    tree=creat();
    mid(tree);
    printf("\n");
    behind(tree);
    printf("\n");
    int t=sum(tree);
    printf("%d\n",t);
    int k=high(tree);
    printf("%d\n",k);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值