Jury Compromise

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury.
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties.
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution.
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties.
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members.
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next.
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.).
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number.
Output an empty line after each test case.

Sample Input

4 2 
1 2 
2 3 
4 1 
6 2 
0 0 

Sample Output

Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 

 

这个状态设计类似于洛谷做过的《多米诺骨牌》。若Σd比Σp小,区间整体偏移到正数就好了。

设f(i,j,k):前i个人,Σd比Σp大(j-400),已选k人对应的Σd+Σp最大值。未定义(不存在)的状态设为f()=-1。

f(i,j,k)=max{f(i-1,j,k),f(i-1,j-x,k-1)+d(i)+p(i)}    , x=d(i)-p(i)

99行,居然一次过,只能是幸运。边界处状态转移一定要搞好。

#include<bits/stdc++.h>
using namespace std;

int n,m,d[205],p[205],f[205][805][25];
int jury,x;

void solve1(int i)
{
	for(int j=0;j<x;j++)for(int k=0;k<=20;k++)
	{
		f[i][j][k]=f[i-1][j][k];
	}				
	for(int j=x;j<=800;j++)
	{
		f[i][j][0]=f[i-1][j][0];
		for(int k=1;k<=m;k++)
		{
			f[i][j][k]=f[i-1][j][k];
			if(f[i-1][j-x][k-1]>=0)
				f[i][j][k]=max(f[i][j][k],f[i-1][j-x][k-1]+d[i]+p[i]);
			
		}
	}
}

void solve2(int i)
{
	for(int j=800+x;j<=800;j++)for(int k=0;k<=20;k++)
	{
		f[i][j][k]=f[i-1][j][k];
	}				
	for(int j=0;j<=800+x;j++)
	{
		f[i][j][0]=f[i-1][j][0];
		for(int k=1;k<=m;k++)
		{
			f[i][j][k]=f[i-1][j][k];
			if(f[i-1][j-x][k-1]>=0)
				f[i][j][k]=max(f[i][j][k],f[i-1][j-x][k-1]+d[i]+p[i]);
			
		}
	}
}

void print()
{
	int add,sub;
	printf("Jury #%d\n",jury);
	for(int i=0;;i++)
	{
		if(f[n][400-i][m]<0&&f[n][400+i][m]<0)continue;
		if(f[n][400-i][m]>f[n][400+i][m])
		{
			add=f[n][400-i][m];
			sub=-1*i;
			break;
		}
		else 
		{
			add=f[n][400+i][m];
			sub=i;
			break;
		}
	}
	int D=(add+sub)/2,P=(add-sub)/2;
	printf("Best jury has value %d for prosecution and value %d for defence:\n",D,P);
	vector<int> ans;
	int j=400+sub,k=m;
	for(int i=n;i>=1;i--)
	{
		if(f[i][j][k]!=f[i-1][j][k])
		{
			ans.push_back(i);
			k--;
			j-=(d[i]-p[i]);
		}
	}
	for(int i=ans.size()-1;i>=0;i--)printf(" %d",ans[i]);
	printf("\n\n");
}

int main()
{
	freopen("input.in","r",stdin);
	memset(f,-1,sizeof(f));
	f[0][400][0]=0;
	while(scanf("%d%d",&n,&m) && n)
	{
		jury++;
		for(int i=1;i<=n;i++)scanf("%d%d",&d[i],&p[i]);
		for(int i=1;i<=n;i++)
		{
			x=d[i]-p[i];
			if(x>=0)solve1(i);
			else solve2(i);
		}
		print();//printf("%d",f[4][398][2]);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值