HDU5671矩阵行列交换

Problem Description
There is a matrix M that has n rows and m columns (1n1000,1m1000) .Then we perform q(1q100,000) operations:

1 x y: Swap row x and row y (1x,yn) ;

2 x y: Swap column x and column y (1x,ym) ;

3 x y: Add y to all elements in row x (1xn,1y10,000) ;

4 x y: Add y to all elements in column x (1xm,1y10,000) ;
 

Input
There are multiple test cases. The first line of input contains an integer T(1T20) indicating the number of test cases. For each test case:

The first line contains three integers n , m and q .
The following n lines describe the matrix M. (1Mi,j10,000) for all (1in,1jm) .
The following q lines contains three integers a(1a4) , x and y .
 

Output
For each test case, output the matrix M after all q operations.
 

Sample Input
  
  
2 3 4 2 1 2 3 4 2 3 4 5 3 4 5 6 1 1 2 3 1 10 2 2 2 1 10 10 1 1 1 2 2 1 2
 





Sample Output
   
   
12 13 14 15 1 2 3 4 3 4 5 6 1 10 10 1
Hint
Recommand to use scanf and printf





#include<cstdio>
#include<algorithm>
#include<cstring>
typedef long long ll;
using namespace std;
int matrix[1001][1001];
struct node
{
    int pos;//位置
    int num;//数值
};
node row[1001],col[1001];
int main()
{
    int T,n,m,x,y,i,j,messege,q;
    node t;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&q);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            scanf("%d",&matrix[i][j]);
        }
        for(i=1;i<=n;i++)
        {
            row[i].pos=i;
            row[i].num=0;
        }
        for(i=1;i<=m;i++)
        {
            col[i].pos=i;
            col[i].num=0;
        }
        while(q--)
        {
            scanf("%d%d%d",&messege,&x,&y);
            switch(messege)
            {
                case 1://记录当前行的数据
                    t=row[x];
                    row[x]=row[y];
                    row[y]=t;
                    break;
                case 2://记录当前列的数据
                    t=col[x];
                    col[x]=col[y];
                    col[y]=t;
                    break;
                case 3:
                    row[x].num+=y;
                    break;
                case 4:
                    col[x].num+=y;
                    break;
            }
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                if(j!=m)
                printf("%d ",matrix[row[i].pos][col[j].pos]+row[i].num+col[j].num);
                else
                printf("%d",matrix[row[i].pos][col[j].pos]+row[i].num+col[j].num);
            }
            printf("\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值