1020 Tree Traversals (25分)(依次二分先序数组,递归构造左右子树)

该代码实现根据后序和中序遍历构建二叉树,并进行层序遍历。给定一棵所有键都为正整数且不重复的二叉树,输入后序和中序遍历序列,输出相应的层序遍历序列。递归函数通过后序遍历的最后一个元素作为根节点,划分中序遍历序列以构建左右子树。
摘要由CSDN通过智能技术生成

1020 Tree Traversals (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

 此代码通过小小的修改也可以变为先序中序找后序等等

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
vector<int> res;
struct node              //节点
{
    int _data;
    node* _left;
    node* _right;

    node(const int& x)
        :_data(x)
        , _left(NULL)
        , _right(NULL)
    {}
};
vector<int> por;        //先序数组
vector<int> inor;      //中序数组

//递归构建左右子树

node*  level(int l,int r){

    node *root=NULL;
    if(l>r){
        return root;    
    }
    for (int i = por.size() - 1; i >= 0;--i ){        //核心代码        从后序数组中从后往前找到左右子树的父母节点,划分inor数组
        int mark = 0;
        for (int j = l; j <=r;++j){
            if(por[i]==inor[j]){
                root = new node(por[i]);      //以这个节点为根构造左右子树
                root->_left= level(l, j-1);
                root->_right=level(j + 1, r);
                mark = 1;
            } 
            if(mark)
                break;           //因为树节点值唯一,只有一种可能,找到根节点就break
        }
          if(mark)
              break;       //同理
    }
    return root;
}

//层序遍历
  void level_order(node* _root)
    {
        queue<node *>q;
        if (_root)
            q.push(_root);
        while (!q.empty())
        {
            node* front = q.front();
            res.push_back(front->_data);
            q.pop();
            if (front->_left)
                q.push(front->_left);
            if (front->_right)
                q.push(front->_right);
        }
    }


int main(){
    int n;
    cin >> n; 
    int t;
    for (int i = 0; i < n;++i){
        cin >> t;
        por.push_back(t);
    }
    for (int i = 0; i < n;++i){
        cin >> t;
        inor.push_back(t);
    }
    node *root;
    root=level(0, n-1);
    level_order(root);
    for (int i = 0; i < res.size()-1;++i){
        cout << res[i]<<" ";
    }
    cout << res[res.size() - 1];
}

 

 

 

 

 

        
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值