(用好指针,树的问题简简单单)1102 Invert a Binary Tree (25分)

 关键点就是找到根节点,因此定义的结构体有个指向父节点的指针,

最后只有一个节点的父节点指针为null,即是根节点,然后遍历。反转遍历只需左右颠倒就行

 

1102 Invert a Binary Tree (25分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

 

#include<iostream>
#include<vector>
#include<queue>


using namespace std;

struct node
{
    int id;
    node *left;
    node *right;
    node *parent;
};

node nodes[10];
vector<int> level;
vector<int> pre;

void levelorder(node* root){
    queue<node *> q;
    q.push(root);
    while(!q.empty()){
        node *first = q.front();
        q.pop();
        level.push_back(first->id);
        if(first->right)
            q.push(first->right);
        if(first->left)
            q.push(first->left);
    }
    
}

void preorder(node* root){
    if(root==NULL)
        return;
    preorder(root->right);
    pre.push_back(root->id);
    preorder(root->left);
}
int main(){
    node k;
    k.left = NULL;
    k.right = NULL;
    k.parent = NULL;
    for (int i = 0; i < 10;++i){
        nodes[i] = k;
    }

        int n;
        cin >> n;
    for (int i = 0; i < n;++i){
        nodes[i].id = i;
        char a, b;
        cin >> a >> b;
        if(a!='-'){
            nodes[i].left = &nodes[a - '0'];
            nodes[a - '0'].parent = &nodes[i];
        }
        if(b!='-'){
            nodes[i].right = &nodes[b - '0'];
            nodes[b - '0'].parent = &nodes[i];
        }
    
    }
    node *root;
    for (int i = 0; i < n;++i){
        if (nodes[i].parent == NULL)
            root = &nodes[i];
    }
    levelorder(root);
    preorder(root);
    for (int i = 0; i < level.size();++i){
        if(i==level.size()-1)
            cout << level[i];
        else
            cout << level[i] << " ";
    }
    cout << endl;
    for (int i = 0; i < pre.size(); ++i)
    {
        if(i==pre.size()-1)
            cout << pre[i];
        else
            cout << pre[i] << " ";
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值