【次短路】POJ3255 Roadblocks

1 篇文章 0 订阅
1 篇文章 0 订阅

Roadblocks

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20419 Accepted: 7157

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers: N and R
Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source

USACO 2006 November Gold


思路:次短路其实就是在最短路的基础上再添进来一条边使得起点到x的最短路+vis[x][y]+y至终点的最短路 最小

跑两遍最短路,再枚举一个边即可


#include <iostream>
#include <cstring>
//#pragma GCC optimize(2)
#include<time.h>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
using namespace std;
#define maxn 5005
#define inf 1e18
#define eps 0.00001
typedef long long ll;
const ll mod = 1e9+7;
const double pi = acos(-1);

ll n,r,ans1[maxn],ans2[maxn];
vector < pair< ll, ll> > arr[maxn];
bool flag[maxn];

struct Why
{
    ll now,dis;
    Why(ll a, ll b)
    {
        now = a;
        dis = b;
    }
    bool operator < (const Why a) const
    {
        return dis > a.dis;
    }

};

void slove(ll x,ll *ans)
{
    priority_queue < Why> A;
    A.push( Why(x,0)  );

    while(!A.empty())
    {
        Why temp = A.top();
        A.pop();

        if( flag[temp.now] == 0 )
        {
            flag[temp.now] = 1;

            ans[ temp.now  ] = min(ans[temp.now],temp.dis );

            for(ll i = 0; i < arr[temp.now].size(); i++)
            {
                A.push( Why( arr[temp.now][i].first, temp.dis+arr[temp.now][i].second  )  );
            }

        }

    }

    return ;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);cout.tie(0);

    //freopen("D:\\test1.in","w",stdout);
    //srand((int)time(0));

    cin >> n >> r;

    memset(ans1,0x3f3f,sizeof(ans1));
    memset(ans2,0x3f3f,sizeof(ans2));

    while(r--)
    {
        ll a,b,c;
        cin >> a >> b >> c;
        arr[a].push_back( make_pair(b,c) );
        arr[b].push_back( make_pair(a,c) );
    }

    slove(1,ans1);
    memset(flag,0,sizeof(flag));
    slove(n,ans2);

    ll ans = inf;

    for(ll i = 1; i <= n; i++)
    {
        for(ll k = 0; k < arr[i].size(); k++)
        {
            if( ans1[i]+ans2[ arr[i][k].first ]+ arr[i][k].second > ans1[n])
                ans = min(ans,ans1[i]+ans2[ arr[i][k].first ]+ arr[i][k].second);
        }
    }
    
    cout << ans << endl;
    
    return 0;
}

 

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值