Red and Black POJ - 1979

5 篇文章 0 订阅
4 篇文章 0 订阅

 

Red and Black

 POJ - 1979 

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
#include<iostream>
#include<queue>
#include<stdio.h>
using namespace std;

int MAXN = 21;
char map[21][21];

struct node{
    int h,w;
};


int moves[4][2] = {{0,-1},{0,1},{-1,0},{1,0}};

int main(){

    int W,H;


    queue<node> que;
    while(scanf("%d %d",&W,&H)!=EOF){
        if(W==0||H==0) break;

        int h_,w_;
        for(int i=0;i<H;i++){
            scanf("%s",&map[i]);
            for(int j=0;j<W;j++){
                if(map[i][j]=='@'){
                    h_ = i;
                    w_ = j;
                }
            }

        }
        node sta;
        sta.h = h_;
        sta.w = w_;

        que.push(sta);
        int count =0;

//        for(int i=0;i<H;i++){
//            for(int j=0;j<W;j++){
//                printf("%c",map[i][j]);
//            }
//            printf("\n");
//        }
        while(!que.empty()){
            node temp = que.front();
            que.pop();
            int h = temp.h;
            int w = temp.w;
            if(map[h][w]=='.'){
                count++;
                map[h][w]= '#';
            }
            for(int j=0;j<4;j++){
                int temp_h =h+moves[j][0];
                int temp_w =w+moves[j][1];
                if((0<=temp_h&&temp_h<H)&&(0<=temp_w&&temp_w<W)){
                    if(map[temp_h][temp_w]=='.'){
                        node t;
                        t.h = temp_h;
                        t.w = temp_w;
                        que.push(t);
                    }
                }
            }
        }

        printf("%d\n",count+1);
    }
    return 0;

}

思路,很简单的广度优先或者深度优先遍历都可以

注意:

1,输入要注意,因为每一行都有回车,所以直接以string 的形式读入

2.遍历过后的地方要设置为“#”红色,避免无限遍历。 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值