A - What Kind of Friends Are You? ZOJ - 3960

6 篇文章 0 订阅
1 篇文章 0 订阅

A - What Kind of Friends Are You?

 ZOJ - 3960 

Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar, all the animals have become anthropomorphized into girls known as Friends.

Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends along the way, and eventually discovers that she is a human.

However, Kaban soon finds that it's also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either "yes" or "no" to identitfy a kind of Friends.

To be more specific, there are n Friends need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals' names that will give a "yes" answer to that question (and those animals who are not in the list will give a "no" answer to that question), so it's possible to determine the name of a Friends by combining the answers and the lists together.

But the work is too heavy for Kaban. Can you help her to finish it?

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T≤ 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤ q ≤ 21), indicating the number of Friends need to be identified and the number of questions.

The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1, p2, ... , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.

For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1, si, 2, ... , si, mi (1 ≤ |si, j| ≤ 20), indicating the number of Friends and their names, who will give a "yes" answer to the i-th question. It's guaranteed that all the names appear in the known names of Friends.

For the following n lines, the i-th line contains q integers ai, 1, ai, 2, ... , ai, q(0 ≤ ai, j ≤ 1), indicating the answer (0 means "no", and 1 means "yes") to the j-th question given by the i-th Friends need to be identified.

It's guaranteed that all the names in the input consist of only uppercase and lowercase English letters.

Output

For each test case output n lines. If Kaban can determine the name of the i-th Friends need to be identified, print the name on the i-th line. Otherwise, print "Let's go to the library!!" (without quotes) on the i-th line instead.

Sample Input

2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1

Sample Output

Serval
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
B
Let's go to the library!!
K

Hint

The explanation for the first sample test case is given as follows:

As Serval is the only known animal who gives a "yes" answer to the 1st, 2nd and 4th question, and gives a "no" answer to the 3rd question, we output "Serval" (without quotes) on the first line.

As no animal is known to give a "no" answer to all the questions, we output "Let's go to the library!!" (without quotes) on the second line.

Both Alpaca and Moose give a "yes" answer to the 1st question, and a "no" answer to the 2nd, 3rd and 4th question. So we can't determine the name of the third Friendsneed to be identified, and output "Let's go to the library!!" (without quotes) on the third line.

题目大意:

给定T个测试案例

对于每个测试案例,给定 需要确定的n 个动物的名字以及 含有 q个询问

再给定  c 个动物, 这个是预先确定好的所有动物的列表,当然最后确定动物的名字也是在这个范围内。

接着是给出 q 个询问的内容

对于每个询问, 包含  m 个动物 以及后续 m个动物的名字

然后再给出 n 个动物分别对 这 q 个问题的回答,以此来确定这n个动物的名字

如果不确定就输出 Let's go to the library!!

题目思路:

对于每一个询问中,如果这个动物在这个序列里面,那么它就会回答 yes 也就是你 这个n*q 的0 1数组来体现

为了确定在这q 个询问中确定这一个动物,要做的就是能够使用方法唯一凸显这个动物的存在,这里可以使用状态压缩的方式

具体的:

就是将每次询问都的状态都用 二进制表示,第i次q询问,就表示二进制的第i位上的值,从而能够表示一个数,把这个数字用hash的形式和动物的名字进行映射,就能快速的找到这个动物。因为最终经过筛选,确定最后一个动物一定是能够保证它对应的映射是唯一的。

然后是对应anser 的问题,做完这个映射之后,我们还要根据anser 数组进行比对,也就是逆向的求解对应的名字。

代码:

#include<iostream>
#include<map>
#include<cstring>
#include<stdio.h>
using namespace std;

map<string,int> q_map;
map<int,string> rec_map;

int T;
int main(){
	scanf("%d",&T);
	while(T--){
		q_map.clear();
		rec_map.clear();
		int n,q;
		scanf("%d%d",&n,&q);
		int c;
		scanf("%d",&c);
		for(int i=0;i<c;i++){
			string a;
			cin>>a;
			q_map[a] = 0;
		}
		for(int i=0;i<q;i++){
			int m;
			scanf("%d",&m);
			for(int j=0;j<m;j++){
				string a;
				cin>>a;
				q_map[a] += (1<<i);
			}
		}
		map<string,int>::iterator it = q_map.begin();
		for(;it!=q_map.end();it++){
			if(rec_map.find(it->second)==rec_map.end()){
				rec_map[it->second] = it->first;
			}else{
				rec_map[it->second] = "Let's go to the library!!";
			}
		}
		for(int i=0;i<n;i++){
			int val=0;
			for(int j=0;j<q;j++){
				int x;
				scanf("%d",&x);
				val +=x*(1<<j);	
			}
			if(rec_map.find(val)!=rec_map.end()){
				printf("%s\n",rec_map[val].c_str());			
			}else{
				printf("Let's go to the library!!\n");
			}
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值