What Kind of Friends Are You? ZOJ - 3960 (STL)

 ZOJ - 3960


Japari Park is a large zoo home to extant species, endangered species, extinct species, cryptids and some legendary creatures. Due to a mysterious substance known as Sandstar, all the animals have become anthropomorphized into girls known asFriends.

Kaban is a young girl who finds herself in Japari Park with no memory of who she was or where she came from. Shy yet resourceful, she travels through Japari Park along with Serval to find out her identity while encountering more Friends along the way, and eventually discovers that she is a human.

However, Kaban soon finds that it's also important to identify other Friends. Her friend, Serval, enlightens Kaban that she can use some questions whose expected answers are either "yes" or "no" to identitfy a kind of Friends.

To be more specific, there are n Friends need to be identified. Kaban will ask each of them q same questions and collect their answers. For each question, she also gets a full list of animals' names that will give a "yes" answer to that question (and those animals who are not in the list will give a "no" answer to that question), so it's possible to determine the name of a Friends by combining the answers and the lists together.

But the work is too heavy for Kaban. Can you help her to finish it?

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T≤ 100), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains two integers n (1 ≤ n ≤ 100) and q (1 ≤q ≤ 21), indicating the number of Friends need to be identified and the number of questions.

The next line contains an integer c (1 ≤ c ≤ 200) followed by c strings p1p2, ... , pc (1 ≤ |pi| ≤ 20), indicating all known names of Friends.

For the next q lines, the i-th line contains an integer mi (0 ≤ mi ≤ c) followed by mi strings si, 1si, 2, ... , simi (1 ≤ |sij| ≤ 20), indicating the number of Friends and their names, who will give a "yes" answer to the i-th question. It's guaranteed that all the names appear in the known names of Friends.

For the following n lines, the i-th line contains q integers ai, 1ai, 2, ... , ai,q (0 ≤ aij ≤ 1), indicating the answer (0 means "no", and 1 means "yes") to thej-th question given by the i-th Friends need to be identified.

It's guaranteed that all the names in the input consist of only uppercase and lowercase English letters.

<h4< dd="">Output

For each test case output n lines. If Kaban can determine the name of the i-thFriends need to be identified, print the name on the i-th line. Otherwise, print "Let's go to the library!!" (without quotes) on the i-th line instead.

<h4< dd="">Sample Input
2
3 4
5 Serval Raccoon Fennec Alpaca Moose
4 Serval Raccoon Alpaca Moose
1 Serval
1 Fennec
1 Serval
1 1 0 1
0 0 0 0
1 0 0 0
5 5
11 A B C D E F G H I J K
3 A B K
4 A B D E
5 A B K D E
10 A B K D E F G H I J
4 B D E K
0 0 1 1 1
1 0 1 0 1
1 1 1 1 1
0 0 1 0 1
1 0 1 1 1
Sample Output
Serval
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
Let's go to the library!!
B
Let's go to the library!!
K
Hint

The explanation for the first sample test case is given as follows:

As Serval is the only known animal who gives a "yes" answer to the 1st, 2nd and 4th question, and gives a "no" answer to the 3rd question, we output "Serval" (without quotes) on the first line.

As no animal is known to give a "no" answer to all the questions, we output "Let's go to the library!!" (without quotes) on the second line.

Both Alpaca and Moose give a "yes" answer to the 1st question, and a "no" answer to the 2nd, 3rd and 4th question. So we can't determine the name of the third Friendsneed to be identified, and output "Let's go to the library!!" (without quotes) on the third line.

题解:

哼哼这个题目读题我至少读了20分钟 题目有点难理解还有点容易T 题目的意思是..    人的名字不会超出m个人这里面的范围
之后对于 每个问题的标准答案就是  比如第一个列子  Serval  在124都出现了有这个人的存在并且就一个一个人满足这个条件所以说就输出这个人的名字
对于第二个样子0000这个情况是没有的因为每个人的名字在下面都出现过所以 说 就输出让他去图书馆    第三个样例是因为1000 因为满足这个样例的有三种情况所以也同样让他去图书馆 题目不好理解以及需要稍微处理下 不然
哼哼这个题目读题我至少读了20分钟 题目有点难理解还有点容易T 题目的意思是..    人的名字不会超出m个人这里面的范围
之后对于 每个问题的标准答案就是  比如第一个列子  Serval  在124都出现了有这个人的存在并且就一个一个人满足这个条件所以说就输出这个人的名字

对于第二个样子0000这个情况是没有的因为每个人的名字在下面都出现过所以 说 就输出让他去图书馆    第三个样例是因为1000 因为满足这个样例的有三种情况所以也同样让他去图书馆 题目不好理解以及需要稍微处理下 不然容易T

处理 是 利用 map 遍历一下每个问题的答案  如果有这个人在这个第一个问题出现就+1否则就加上0

代码:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,q;
        scanf("%d%d",&n,&q);
        int m,c;
        scanf("%d",&m);
        string s[205];
        for(int i=1;i<=m;i++)
        	cin>>s[i];//设置他们的输入的情况 
		map<string,int>mp;
		string hh[205];
        for(int i=1;i<=q;i++)
        {
            int c;
            scanf("%d",&c);//这个表示的是 每个这个都是几个人 然后 可以开始map 
         	map<string,bool>mm;
         	string gg;
			for(int j=1;j<=c;j++)  
            {
            	cin>>gg;
            	mm[gg]=true;
            }	
            for(int k=1;k<=m;k++)
            {
            	if(mm[s[k]]==true)
            	hh[k]+='1';
            	else hh[k]+='0';
            }
        }
        for(int i=1;i<=m;i++)
        	mp[hh[i]]++;
        int x;
        for(int i=1;i<=n;i++)
        {
        	string ll;
        	for(int j=1;j<=q;j++)
        	{
        		scanf("%d",&x);
        		ll+=x+'0';
        	}
        	if(mp[ll]==1)
        	{
        		for(int j=1;j<=m;j++)
        		{
        			if(ll==hh[j])
        			{
        				cout<<s[j]<<endl;
        				break; 
        			}	
        		}
        		
        	}else  cout<<"Let's go to the library!!"<<endl;;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值