Sliding Window POJ - 2823

Sliding Window

 POJ - 2823 

An array of size n ≤ 10 6 is given to you. There is a sliding window of size kwhich is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.

Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题目大意:

给定一个序列长度N,并给出窗口大小k

从左到右,以卷积的形式进行滑动,给出滑动窗口里的最大值和最小值

思路:

如果滑动窗口k=n/2 的话,直接遍历将会超时,所以这里使用线段树进行求解,对应的

先对二分的每个区间计算好最大和最小值,然后查询进行查询即可最后复杂度为nlogn

代码:

#include<iostream>
#include<cstdio>
const int MAXN = 1e6+10;

using namespace std;

struct node{
	int left,right;
	int amax,amin;
}Arr[4*MAXN];

int arr[MAXN];
const int INF = 0x3f3f3f3f;
const int MINF = 0x80000000;

void create(int root,int left,int right){
	Arr[root].left = left;
	Arr[root].right = right;
	if(right-left==1){
		Arr[root].amax = Arr[root].amin = arr[left];
		return;
	}
	int mid = (left+right)/2;
	
	create(root*2,left,mid);
	create(root*2+1,mid,right);
	Arr[root].amax = max(Arr[root*2].amax,Arr[root*2+1].amax);
	Arr[root].amin = min(Arr[root*2].amin,Arr[root*2+1].amin);
}

//type==1 max ,==2 min 
int quary(int root,int ll,int rr,int type){
	if(ll>=Arr[root].right || rr<=Arr[root].left) return type==1? MINF:INF;
	if(rr>=Arr[root].right && ll<=Arr[root].left) return type==1?Arr[root].amax:Arr[root].amin;	
	
	int a = quary(root*2,ll,rr,type);
	int b = quary(root*2+1,ll,rr,type);
	
	if(type==1)
		return max(a,b);
	return min(a,b);
}

int N,K; 
int main(){
	
	scanf("%d%d",&N,&K);
	
	for(int i=1;i<=N;i++){
		scanf("%d",&arr[i]);
	}
	create(1,1,1+N);
	
	for(int i=1;i<=N-K+1;i++){
		printf(i==1?"%d":" %d",quary(1,i,i+K,2));	
	}
	printf("\n");
	for(int i=1;i<=N-K+1;i++){
		printf(i==1?"%d":" %d",quary(1,i,i+K,1));	
	}
	printf("\n");
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值