hdu3549 Flow Problem(最大流)

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 10462    Accepted Submission(s): 4927


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
  
  
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
  
  
Case 1: 1 Case 2: 2
 

题意:t个测试数据,n个结点,m条水管,给出每条水管的最大流量,求从第一个结点流向最后一个结点,最多的水流量。

跟poj1273一样,也是典型的最大流模板题,套用Dinic算法的模板。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define maxn 20

using namespace std;

int m, n, s, e, c;
int maps[maxn][maxn], q[maxn * maxn];
int d[maxn];//记录每个点所在的层

int BFS()//BFS分层,判断是否存在增广路
{
    memset(d, -1, sizeof(d));
    d[1] = 0;
    int f, r;
    f = 1;
    r = 1;
    q[r++] = 1;
    while(f < r)
    {
        int x = q[f++];
        for(int i = 1; i <= n; i++)
        {
            if(d[i] < 0 && maps[x][i] > 0)
            {
                d[i] = d[x] + 1;
                q[r++] = i;
            }
        }
    }
    if(d[n] > 0)
        return 1;
    else
        return 0;
}

int Find(int x, int v)//找出某一条增广路的最大流
{
    int a;
    if(x == n)
        return v;
    for(int i = 1; i <= n; i++)
    {
        if(maps[x][i] > 0 && d[i] == d[x] + 1 && (a = Find(i, min(v, maps[x][i]))))//x到i有流量 且 i是x的下一层 且 i到汇点存在最大流
        {
            maps[x][i] -= a;//增广路
            maps[i][x] += a;//回退边
            return a;
        }
    }
    return 0;
}

int main()
{
    int ans, t, cases, cnt;
    scanf("%d", &cases);
    cnt = 1;
    while (cases--)
    {
        scanf("%d%d", &n, &m);
        ans = 0;
        memset(maps, 0, sizeof(maps));
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d", &s, &e, &c);
            maps[s][e] += c;
        }
        while(BFS())//BFS搜索判断是否有从源点到汇点的通路
        {
            while(t = Find(1, 2000000005))//查找增广路,求其最大流
                ans += t;
        }
        printf("Case %d: %d\n", cnt++, ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值