poj1274 The Perfect Stall(二分图匹配 / 最大流)

The Perfect Stall
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20547 Accepted: 9263

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

题意:n头牛,m个位置,每头牛可以待在s个位置上,给每个牛分配一个位置,求问最多几头牛可以分配到位置。

这是二分图匹配的基础题,也可以用最大流来做,直接贴代码。。

二分图匹配:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define maxn 205

using namespace std;

int maps[maxn][maxn], vis[maxn], link[maxn];
int n, m;

bool Find(int x)
{
    for(int i = 1; i <= m; i++)
    {
        if(vis[i] == 0 && maps[x][i] == 1)
        {
            vis[i] = 1;
            if(link[i] == 0 || Find(link[i]))
            {
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int x, y;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        memset(maps, 0, sizeof(maps));
        memset(link, 0, sizeof(link));
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", &x);
            for(int j = 0; j < x; j++)
            {
                scanf("%d", &y);
                maps[i][y] = 1;
            }
        }
        int ans = 0;
        for(int i = 1; i <= n; i++)
        {
            memset(vis, 0, sizeof(vis));
            if(Find(i))
                ans++;
        }
        printf("%d\n", ans);
    }
}

网络流最大流:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

#define maxn 505

using namespace std;

int n, m;
int maps[maxn][maxn], q[maxn * maxn];
int d[maxn];//记录每个点所在的层

int BFS()//BFS分层,判断是否存在增广路
{
    memset(d, -1, sizeof(d));
    d[0] = 0;
    int f, r;
    f = 1;
    r = 1;
    q[r++] = 0;
    while(f < r)
    {
        int x = q[f++];
        for(int i = 0; i <= n + m + 1; i++)
        {
            if(d[i] < 0 && maps[x][i] > 0)
            {
                d[i] = d[x] + 1;
                q[r++] = i;
            }
        }
    }
    if(d[n + m + 1] > 0)
        return 1;
    else
        return 0;
}

int Find(int x, int v)//找出某一条增广路的最大流
{
    int a;
    if(x == n + m + 1)
        return v;
    for(int i = 0; i <= n + m + 1; i++)
    {
        if(maps[x][i] > 0 && d[i] == d[x] + 1 && (a = Find(i, min(v, maps[x][i]))))//x到i有流量 且 i是x的下一层 且 i到汇点存在最大流
        {
            maps[x][i] -= a;//增广路
            maps[i][x] += a;//回退边
            return a;
        }
    }
    return 0;
}

int main()
{
    int x, y, t;
    while(scanf("%d%d", &n, &m) != EOF)
    {
        memset(maps, 0, sizeof(maps));
        for(int i = 1; i <= n; i ++)
        {
            scanf("%d", &x);
            for(int j = 1; j <= x; j ++)
            {
                scanf("%d", &y);
                maps[i][n + y] = 1;
            }
        }
        for(int i = 1; i <= n; i++)
            maps[0][i] = 1;
        for(int i = n + 1; i <= n + m; i++)
            maps[i][n + m + 1] = 1;
//        for(int i = 0; i <= n + m + 1; i++)
//        {
//            for(int j = 0; j <= n + m + 1; j++)
//            {
//                printf("%d ",maps[i][j]);
//            }
//            printf("\n");
//        }
        int ans = 0;
        while(BFS())//BFS搜索判断是否有从源点到汇点的通路
        {
            while(t = Find(0, 2000000005))//查找增广路,求其最大流
                ans += t;
        }
        printf("%d\n", ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于YOLOv9实现工业布匹缺陷(破洞、污渍)检测系统python源码+详细运行教程+训练好的模型+评估 【使用教程】 一、环境配置 1、建议下载anaconda和pycharm 在anaconda中配置好环境,然后直接导入到pycharm中,在pycharm中运行项目 anaconda和pycharm安装及环境配置参考网上博客,有很多博主介绍 2、在anacodna中安装requirements.txt中的软件包 命令为:pip install -r requirements.txt 或者改成清华源后再执行以上命令,这样安装要快一些 软件包都安装成功后才算成功 3、安装好软件包后,把anaconda中对应的python导入到pycharm中即可(不难,参考网上博客) 二、环境配置好后,开始训练(也可以训练自己数据集) 1、数据集准备 需要准备yolo格式的目标检测数据集,如果不清楚yolo数据集格式,或者有其他数据训练需求,请看博主yolo格式各种数据集集合链接:https://blog.csdn.net/DeepLearning_/article/details/127276492 里面涵盖了上百种yolo数据集,且在不断更新,基本都是实际项目使用。来自于网上收集、实际场景采集制作等,自己使用labelimg标注工具标注的。数据集质量绝对有保证! 本项目所使用的数据集,见csdn该资源下载页面中的介绍栏,里面有对应的下载链接,下载后可直接使用。 2、数据准备好,开始修改配置文件 参考代码中data文件夹下的banana_ripe.yaml,可以自己新建一个不同名称的yaml文件 train:训练集的图片路径 val:验证集的图片路径 names: 0: very-ripe 类别1 1: immature 类别2 2: mid-ripe 类别3 格式按照banana_ripe.yaml照葫芦画瓢就行,不需要过多参考网上的 3、修改train_dual.py中的配置参数,开始训练模型 方式一: 修改点: a.--weights参数,填入'yolov9-s.pt',博主训练的是yolov9-s,根据自己需求可自定义 b.--cfg参数,填入 models/detect/yolov9-c.yaml c.--data参数,填入data/banana_ripe.yaml,可自定义自己的yaml路径 d.--hyp参数,填入hyp.scratch-high.yaml e.--epochs参数,填入100或者200都行,根据自己的数据集可改 f.--batch-size参数,根据自己的电脑性能(显存大小)自定义修改 g.--device参数,一张显卡的话,就填0。没显卡,使用cpu训练,就填cpu h.--close-mosaic参数,填入15 以上修改好,直接pycharm中运行train_dual.py开始训练 方式二: 命令行方式,在pycharm中的终端窗口输入如下命令,可根据自己情况修改参数 官方示例:python train_dual.py --workers 8 --device 0 --batch 16 --data data/coco.yaml --img 640 --cfg models/detect/yolov9-c.yaml --weights '' --name yolov9-c --hyp hyp.scratch-high.yaml --min-items 0 --epochs 500 --close-mosaic 15 训练完会在runs/train文件下生成对应的训练文件及模型,后续测试可以拿来用。 三、测试 1、训练完,测试 修改detect_dual.py中的参数 --weights,改成上面训练得到的best.pt对应的路径 --source,需要测试的数据图片存放的位置,代码中的test_imgs --conf-thres,置信度阈值,自定义修改 --iou-thres,iou阈值,自定义修改 其他默认即可 pycharm中运行detect_dual.py 在runs/detect文件夹下存放检测结果图片或者视频 【特别说明】 *项目内容完全原创,请勿对项目进行外传,或者进行违法等商业行为! 【备注】 1、该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的,请放心下载使用!有问题请及时沟通交流。 2、适用人群:计算机相关专业(如计科、信息安全、数据科学与大数据技术、人工智能、通信、物联网、自动化、电子信息等)在校学生、专业老师或者企业员工下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值