The Triangle poj-1163

Language:DefaultEspañol
The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 53422 Accepted: 32266

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;


int d[110][110];//存数据
int maxsum[110][110];//记录走的步数的值
int n;//行数


int dfs(int i,int j)//表示从i,j到最低边的最大值
{
    if(maxsum[i][j]!=-1)//如果走过了就返回
        return maxsum[i][j];
    if(i==n)//如果在最后一行
        maxsum[i][j]=d[i][j];//返回它本身
    else
    {
        int x=dfs(i+1,j);//往下走
        int y=dfs(i+1,j+1);//往右下走
        maxsum[i][j]=max(x,y)+d[i][j];//保证最大值
    }
    return maxsum[i][j];//返回步数的值
}


int main()
{
    while(cin>>n)//输入行数
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                cin>>d[i][j];//输入地图
            }
        }
        memset(maxsum,-1,sizeof(maxsum));//初始化,表示都没走过
        cout<<dfs(1,1)<<endl;//从最上面开始到底端的最大值
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值