POJ 1163

初入dp,第一道dp题

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

题意:给出的这一颗树,从顶部到底部有很多条路,从中选出一条走过的每个点的数字相加要最大的一条路

思路: 可以从顶部一直向下加,但是要注意有些层的数字个数是奇数,所以中间的数到上面的数有两条路,所以我们只需要选一个最大的就可以了

AC代码:

import java.util.Scanner;

public class Main {
    private static int num = 0;
    private static int[][] dp = new int[200][200];
    private static int[][] memory = new int[200][200];

    public static void main(String[] args) {
    Scanner scanner = new Scanner(System.in);
    num = scanner.nextInt();
    for (int i = 1; i <= num; i++) {
        for (int j = 1; j <= i; j++) {
        memory[i][j] = scanner.nextInt();
        }
    }
    for (int i = 1; i <= num; i++) {
        for (int j = 1; j <= i; j++) {
        if (i == 1) {
            dp[i][j] = memory[i][j];
        } else if (j == 1) {
            dp[i][j] = dp[i - 1][j] + memory[i][j];
        } else if (j == i) {
            dp[i][j] = dp[i - 1][j - 1] + memory[i][j];
        } else {
            dp[i][j] = getMax(dp[i - 1][j], dp[i - 1][j - 1])
                + memory[i][j];
        }
        }
    }
    int result =0;
    for (int i = 1; i <= num; i++) 
        result = getMax(result, dp[num][i]);
    System.out.println(result);
    scanner.close();
    }

    private static int getMax(int x, int y) {
    if (x > y) {
        return x;
    }
    return y;
    }
}

*最后根据结果来分析一下:

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5


最后dp数组:
7 
10 15 
18 16 15 
20 25 20 19 
24 30 27 26 24 

从上面的两组数据不难看出,思路就是一直往下加,只需要在一个点有用两个节点的时候判断一下路程大小就可以了*

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值