Twice Equation

问题 L: Twice Equation

时间限制: 1 Sec   内存限制: 128 MB
提交: 50   解决: 25
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

For given L, find the smallest n no smaller than L for which there exists an positive integer m for which 2m(m + 1) = n(n + 1).

输入

This problem contains multiple test cases. The first line of a multiple input is an integer T (1 ≤ T < 1000) followed  by T input lines. Each line contains an integer L (1 ≤ L < 10190 ).

输出

For each given L, output the smallest n. If available n does not exist, output −1.

样例输入

3

1

4

21

样例输出

3

20
119

import java.math.*;
import java.util.*;
public class Main {

public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner input = new Scanner(System.in);

BigInteger[] daan = new BigInteger[1010];
daan[1] = BigInteger.valueOf(3);
daan[2] = BigInteger.valueOf(20);

BigInteger s[] = new BigInteger[2];
s[0] = BigInteger.valueOf(6);
s[1] = BigInteger.valueOf(2);

for(int i=3; i<=1000; i++)
{
daan[i] = daan[i-1].multiply(s[0]);
daan[i] = daan[i].subtract(daan[i-2]);
daan[i] = daan[i].add(s[1]);
}
int qwe = 0;
int t = input.nextInt();
while(t>0)
{
BigInteger x = input.nextBigInteger();
for(int j=1; j<=310; j++)///190次幂开6次方就大约是310组答案
{
if(x.compareTo(daan[j])<0)
{
qwe = 1;
System.out.println(daan[j]);
break;
}
else if(j == 310 && qwe == 0)
{
System.out.println(-1);
}
}
t=t-1;
}
}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值