Twice Equation(递推+java大数)

问题 L: Twice Equation

题目描述

For given L, find the smallest n no smaller than L for which there exists an positive integer m for which 2m(m + 1) = n(n + 1).

输入

This problem contains multiple test cases. The first line of a multiple input is an integer T (1 ≤ T < 1000) followed  by T input lines. Each line contains an integer L (1 ≤ L < 10190 ).

输出

For each given L, output the smallest n. If available n does not exist, output −1.

样例输入

3
1
4
21

样例输出

3
20
119

先用的c++打出前几项然后找出了一个递推的规律fn=f(n-1)*6-f(n-2)+2,然后就是直接用java大数直接while模拟递推就可以。

import java.math.BigInteger;
import java.util.Scanner;
public class Main {
    public static void main(String[] args){
        Scanner cin = new Scanner(System.in);
        int t;
         
        t=cin.nextInt();
        while (t--!=0){
            BigInteger n,a,b,c;
            n=cin.nextBigInteger();
            if(n.compareTo(BigInteger.valueOf(3))<=0) {
                System.out.println("3");
                continue;
            }
            if(n.compareTo(BigInteger.valueOf(20))<=0) {
                System.out.println("20");
                continue;
            }
             
            a=BigInteger.valueOf(3);
            b=BigInteger.valueOf(20);
            while(true) {
                c=b.multiply(BigInteger.valueOf(6)).subtract(a).add(BigInteger.valueOf(2));
                if(c.compareTo(n)>=0) {
                    System.out.println(c);
                    break;
                }
                a=b;
                b=c;
            }
        }       
    }
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值