BNUOJ Best SMS To Type

Best SMS to Type

1000ms
65536KB
This problem will be judged on PKU. Original ID: 2895
64-bit integer IO format: %lld      Java class name: Main
Font Size:
Type:
Using SMS today is more than a pleasing hobby. As the number of messages one sends through this service grows, the need to type them fast is better felt. Sometimes, one wonders how fast a message can be typed. Changing some words to their synonyms, might help type the whole message faster, if we were able to quickly calculate the time needed for a specific message.

In the following, we assume that each message is a string of capital English letters and space character. The letters 'A' through 'Z' are assigned to keys '2' to '9', as in the following figure. To type a letter, one should press its key 1, 2, 3, or 4 times, depending on the position of the letter from left to right.

If two consecutive letters of the message are mapped to one key, one should wait for the first letter to be fixed on the screen and then use the key again to type the second one. For instance, to type the letter 'X', one should press '9' twice. If the next letter of the message is not on the same key, one can continue to type the rest of the message. Otherwise, one has to wait for some time, so that the typed 'X' is fixed, and then the next letter ('W', 'X', 'Y', or 'Z') can be typed. To type whitespace, we use the key '1'.As there is no letter mapped to the key '1', the whitespace needs no time to be fixed.

You are given the time needed to press any key, and the time one should wait for a letter to be fixed. Your program should find the minimum time needed to type a nonempty string, given the above rules.

Input

The input file contains multiple test cases. The first line of the input, contains t, the number of test cases that follow. Each of the following t blocks, describes a test case.

The first line of each block contains p and w (1 <= p,w <= 1000), which show the amount of time in milliseconds for pressing a letter and waiting for it to be fixed, respectively. The second line contains a non-empty string of length at most 1000, consisting of spaces or capital English letters. There is no leading or trailing spaces in a line.

Output

For each test case, output one line showing the time needed to type the message in milliseconds.

Sample Input

1
2 10
ABBAS SALAM

Sample Output

72

 

很水的模拟题,注意: 可能有连续输入的空格。。。

 

#include<stdio.h>
#include<string.h>
char str[1005];
long long sum;
int a[1005];
int s[8][4]={{'A','B','C','0'},{'D','E','F','0'},{'G','H','I','0'},{'J','K','L','0'},
              {'M','N','O','0'},{'P','Q','R','S'},{'T','U','V','0'},{'W','X','Y','Z'}};
int main()
{
 int t,i,j,n,p,w,k;
 while(scanf("%d",&n)!=EOF)
 {
     while(n--){
   sum=0;
      scanf("%d%d",&p,&w);   // p: 按一次键需要的时间,w: 同一个键上的字符间隔时间
   getchar(); 
      gets(str);
      memset(a,0,sizeof(a));
      t=0;
   for(i=0;i<strlen(str);i++){
       if(str[i]==' ') { a[t++]=-1; sum+=p;  }
       else {
        for(j=0;j<8;j++)
            for(k=0;k<4;k++)
             if(str[i]==s[j][k]){
              sum+=((k+1)*p);
              a[t++]=j;
             } 
       }
   }
   for(i=0;i<t-1;i++)
       if(a[i]==a[i+1] && a[i]!=-1)  sum+=w;
   printf("%lld\n",sum);
  } 
    }
    system("pause");
 return 0; 
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值