畅通工程再续(HDU - 1875)(Kruskal算法求最小生成树)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 45382    Accepted Submission(s): 15261

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1875

Problem Description

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input

输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。

每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

Output

每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input

2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output
1414.2
oh!

解题思路:

求最小生成树,先把坐标存起来,然后求各个岛之间的距离,选择满足条件的,用Kruskal(克鲁斯卡尔)算法求最小生成树,如果不能构成最小生成树,则输出”oh!”

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<functional>
#include<cmath>
using namespace std;
int link[105];	//并查集,检验两个点是否相连
void init(int n){    //初始化并查集
	for(int i = 0; i <= n; i++){
		link[i] = i;
	}
}
struct island{	//自定义结构体,存岛的位置坐标
	double x,y;
}mp[105];
double len(struct island a,struct island b){	//求两个岛之间的距离
	double x = a.x - b.x;
	double y = a.y - b.y;
	return sqrt(x*x+y*y);
}
struct node{	//自定义结构体,存一条边
	int bg,ed;	//边的起点和终点
	double cs;	//边的权重,也就是起点到终点的距离
	bool operator < (const node& next) const{	//重载小于运算符,使得结构体在优先队列中,权重小的优先
		return cs > next.cs;
	}
};
int fd(int n){	//并查集,查找这个点属于哪个集合
	if(link[n] == n) return n;
	else return link[n] = fd(link[n]);
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		int n;
		scanf("%d",&n);
		init(n);
		for(int i = 1; i <= n; i++){	//读入每个岛的位置坐标
			scanf("%lf%lf",&mp[i].x,&mp[i].y);
		}
		priority_queue<struct node> q;
		while(!q.empty()) q.pop();
		struct node now;
		for(int i = 1; i <= n; i++){
			for(int j = i+1; j <= n; j++){
				now.bg = i;
				now.ed = j;
				now.cs = len(mp[i],mp[j]);
				if( now.cs >= 10.0  && now.cs <= 1000 ){
					q.push(now);
				}
			}
		}
		int bs = 0;	//记录已经找到的边数
		double ans = 0;	//记录最小生成树的费用
		while(!q.empty() && bs != n-1){	//每次找费用最小的边
			now = q.top();
			q.pop();
			int nb = now.bg;
			int ne = now.ed;
			int fnb = fd(nb);
			int fne = fd(ne);
			if(fnb != fne){	//判断这条边相连的两个点是否相连,如果不相连,则加上这条边
				ans+=now.cs;
				bs++;
				link[fnb] = fne;
			}
		}
		if(bs == n-1){	//判断是否构成最小生成树
			printf("%.1lf\n",ans*100.0);
		} 
		else{
			printf("oh!\n");
		}
	}
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值