还是畅通工程(HDU - 1233)(Kruskal算法求最小生成树)

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 70755    Accepted Submission(s): 32040

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1233

Problem Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。

当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3
5

解题思路:

最小生成树,用Kruskal(克鲁斯卡尔)算法求最小生成树。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<functional>
using namespace std;
int link[500];	//并查集,检验两个点是否相连
struct node{	//自定义结构体,存一条边
	int bg,ed,cs;	//边的起点和终点以及边的权重,也就是起点到终点的距离
	bool operator < (const node& next) const{	//重载小于运算符,使得结构体在优先队列中,权重小的优先
		return cs > next.cs;
	} 
};
void init(int n){	//初始化并查集
	for(int i = 0; i <= n; i++){
		link[i] = i;
	}
}
int fd(int n){	//并查集,查找这个点属于哪个集合
	if(link[n] == n) return n;
	else return link[n] = fd(link[n]);
}
int main(){
	int n;
	while(~scanf("%d",&n) && n != 0){
		init(n);
		priority_queue<struct node> q;
		while(!q.empty())  q.pop();
		struct node now;
		for(int i = 0; i < n*(n-1)/2; i++){
			scanf("%d%d%d",&now.bg,&now.ed,&now.cs);
			q.push(now);
		}
		int bs = 0;
		int ans = 0;
		while(!q.empty() && bs != n-1){		//每次找费用最小的边
			now = q.top();
			q.pop();
			int nb = now.bg;
			int ne = now.ed;
			int fnb = fd(nb);
			int fne = fd(ne);
			if(fnb != fne){		//判断这条边相连的两个点是否相连,如果不相连,则加上这条边
				ans+=now.cs; 
				bs++;
				link[fnb] = fne;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值