Muddy roads

 

Farmer John has a problem: the dirt road from his farm to town has suffered in the recent rainstorms and now contains (1 <= N <= 10,000) mud pools. 

Farmer John has a collection of wooden planks of length L that he can use to bridge these mud pools. He can overlap planks and the ends do not need to be anchored on the ground. However, he must cover each pool completely. 

Given the mud pools, help FJ figure out the minimum number of planks he needs in order to completely cover all the mud pools.

Input

* Line 1: Two space-separated integers: N and L 

* Lines 2..N+1: Line i+1 contains two space-separated integers: s_i and e_i (0 <= s_i < e_i <= 1,000,000,000) that specify the start and end points of a mud pool along the road. The mud pools will not overlap. These numbers specify points, so a mud pool from 35 to 39 can be covered by a single board of length 4. Mud pools at (3,6) and (6,9) are not considered to overlap. 

Output

* Line 1: The miminum number of planks FJ needs to use.

Sample Input

3 3
1 6
13 17
8 12

Sample Output

5

Hint

INPUT DETAILS: 

FJ needs to use planks of length 3 to cover 3 mud pools. The mud pools cover regions 1 to 6, 8 to 12, and 13 to 17. 

OUTPUT DETAILS: 

FJ can cover the mud pools with five planks of length 3 in the following way: 

                   111222..333444555....

                   .MMMMM..MMMM.MMMM....

                   012345678901234567890

 

 

 

将水坑的区间从小到大排序,另外分析一块木板可以遮盖多个水坑的情况

 

 

#include<iostream>
#include<string.h>
#include<algorithm>
#include<cmath>
using namespace std;
struct node{
	int x, y;
};
node s[10005];
bool cmp(node &a, node &b)
{
	return a.x < b.x;
}
int main()
{
	int n, L, p, ans, k;
	while(cin>>n>>L)
	{
		ans = 0;
		for(int i = 0; i < n; i++)
		{
			cin>>s[i].x>>s[i].y;
		}
		sort(s, s + n, cmp);
		k = 0;
		for(int i = 0; i < n; i++)
		{
			if(k > s[i].x && k >= s[i].y)
				continue;
			if(k <= s[i].x)
				k = s[i].x;
			if((s[i].y - k) % L != 0)
				p = (s[i].y - k) / L + 1;
			else
				p = (s[i].y - k) / L;
			ans += p;
			k += p * L;
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值