【HDU 1495】 非常可乐 (bfs + 模拟)

 

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。

Input

三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。

Output

如果能平分的话请输出最少要倒的次数,否则输出"NO"。

Sample Input

7 4 3
4 1 3
0 0 0

Sample Output

NO
3

 

 

 

据大佬说这道题除了模拟还有一种解法,依据一个数学公式,感兴趣可以自己看一下长度远比模拟短

 

/*
    bfs + 模拟
    开始时:S杯满, M, N杯为空, 最终S杯与max(M, N)杯分别装有S杯的一半
    模拟有六种情况,S -> M, S -> N, M -> S, M -> N, N -> S, N -> M, 按此顺序倒可乐
    如果之前未判断此种情况,加入队列切标记已遍历
*/

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
const int MX = 105;
int s, m, n, vis[MX][MX];
struct Node{
    int x, y, s, step;
};
int bfs()
{
    queue<Node> q;
    Node now;
    now.x = 0;
    now.y = 0;
    now.s = s;
    now.step = 0;
    q.push(now);
    vis[m][n] = 1;
    while(!q.empty())
    {
        now = q.front();
        Node node;
        q.pop();
        if(now.x == s / 2 && now.s == s / 2)
        {
            return now.step;
        }
        if(now.s != 0 && now.x != m)
        {
            int x = m - now.x;
            if(now.s >= x)
            {
                node.s = now.s - x;
                node.x = m;
            }
            else
            {
                node.s = 0;
                node.x = now.x + now.s;
            }
            node.y = now.y;
            node.step = now.step + 1;
            if(vis[node.x][node.y] == 0)
            {
                vis[node.x][node.y] = 1;
                q.push(node);
            }
        }
        if(now.s != 0 && now.y != n)
        {
            int x = n - now.y;
            if(now.s >= x)
            {
                node.s = now.s - x;
                node.y = n;
            }
            else
            {
                node.s = 0;
                node.y = now.y + now.s;
            }
            node.x = now.x;
            node.step = now.step + 1;
            if(vis[node.x][node.y] == 0)
            {
                vis[node.x][node.y] = 1;
                q.push(node);
            }
        }
        if(now.x != 0 && now.s != s)
        {
            int x = s - now.s;
            if(now.x >= x)
            {
                node.x = now.x - x;
                node.s = s;
            }
            else
            {
                node.x = 0;
                node.s = now.s + now.x;
            }
            node.y = now.y;
            node.step = now.step + 1;
            if(vis[node.x][node.y] == 0)
            {
                vis[node.x][node.y] = 1;
                q.push(node);
            }
        }
        if(now.x != 0 && now.y != n)
        {
            int x = n - now.y;
            if(now.x >= x)
            {
                node.x = now.x - x;
                node.y = n;
            }
            else
            {
                node.x = 0;
                node.y = now.y + now.x;
            }
            node.s = now.s;
            node.step = now.step + 1;
            if(vis[node.x][node.y] == 0)
            {
                vis[node.x][node.y] = 1;
                q.push(node);
            }
        }
        if(now.y != 0 && now.s != s)
        {
            int x = s - now.s;
            if(now.y >= x)
            {
                node.y = now.y - x;
                node.s = s;
            }
            else
            {
                node.y = 0;
                node.s = now.s + now.y;
            }
            node.x = now.x;
            node.step = now.step + 1;
            if(vis[node.x][node.y] == 0)
            {
                vis[node.x][node.y] = 1;
                q.push(node);
            }
        }
        if(now.y != 0 && now.x != m)
        {
            int x = m - now.x;
            if(now.y >= x)
            {
                node.y = now.y - x;
                node.x = m;
            }
            else
            {
                node.y = 0;
                node.x = now.x + now.y;
            }
            node.s = now.s;
            node.step = now.step + 1;
            if(vis[node.x][node.y] == 0)
            {
                vis[node.x][node.y] = 1;
                q.push(node);
            }
        }
    }
    return -1;
}
int main()
{
    while(scanf("%d%d%d", &s, &m, &n) != EOF && (s + m + n))
    {
        memset(vis, 0, sizeof(vis));
        if(s & 1)
        {
            printf("NO\n");
            continue;
        }
        if(m < n)
            swap(m, n);
        int x = bfs();
        if(x != -1)
            printf("%d\n", x);
        else
            printf("NO\n");
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值