HDU 3506 Monkey Party

Far away from our world, there is a banana forest. And many lovely monkeys live there. One day, SDH(Song Da Hou), who is the king of banana forest, decides to hold a big party to celebrate Crazy Bananas Day. But the little monkeys don't know each other, so as the king, SDH must do something.
Now there are n monkeys sitting in a circle, and each monkey has a making friends time. Also, each monkey has two neighbor. SDH wants to introduce them to each other, and the rules are:
1.every time, he can only introduce one monkey and one of this monkey's neighbor.
2.if he introduce A and B, then every monkey A already knows will know every monkey B already knows, and the total time for this introducing is the sum of the making friends time of all the monkeys A and B already knows;
3.each little monkey knows himself;
In order to begin the party and eat bananas as soon as possible, SDH want to know the mininal time he needs on introducing.
 

Input
There is several test cases. In each case, the first line is n(1 ≤ n ≤ 1000), which is the number of monkeys. The next line contains n positive integers(less than 1000), means the making friends time(in order, the first one and the last one are neighbors). The input is end of file.
 

Output
For each case, you should print a line giving the mininal time SDH needs on introducing.
 

Sample Input
  
  
8 5 2 4 7 6 1 3 9
 

Sample Output
105

解题思路:这道题目的本质其实就是石子合并问题,只是在一个环上处理而已,我们可以在第n个元素之后添加前面的元素来处理环的情况,本题n的范围1010,因此我们需要用到石子合并问题的优化方法,石子合并优化问题,网上有很多参考资料的。

#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <utility>
#include <algorithm>
#include <functional>
using namespace std;
const int maxn = 2010;
const int inf  = 0x3f3f3f3f;
int arr[maxn], sum[maxn];
int dp[maxn][maxn], s[maxn][maxn];
int n, m;

int main() {

    //freopen("aa.in", "r", stdin);

    while(scanf("%d", &n) != EOF) {
        sum[0] = 0;
        for(int i = 1; i <= n; ++i) {
            scanf("%d", &arr[i]);
            sum[i] = sum[i-1] + arr[i];
        }
        for(int i = n + 1; i < 2*n; ++i) {
            arr[i] = arr[i-n];
            sum[i] = sum[i-1] + arr[i];
        }
        m = 2 * n - 1;
        for(int i = 1; i <= m; ++i) {
            dp[i][i] = 0;
            s[i][i] = i;
        }
        for(int l = 1; l < n; ++l) {
            for(int i = 1; i + l <= m; ++i) {
                int j = i + l;
                dp[i][j] = inf;
                for(int k = s[i][j-1]; k <= s[i+1][j]; ++k) {
                    if(dp[i][j] > dp[i][k] + dp[k+1][j] + sum[j] - sum[i-1]) {
                        dp[i][j] = dp[i][k] + dp[k+1][j] + sum[j] - sum[i-1];
                        s[i][j] = k;
                    }
                }
            }
        }
        int ans = inf;
        for(int i = 1; i + n - 1 <= m; ++i) {
            ans = min(ans, dp[i][i+n-1]);
        }
        printf("%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值