HDU 3001 Travelling

Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
解题思路:一个裸的TSP问题,但是要注意的是每个点最多可以访问2次,访问一次我们用二进制来表示状态,访问两次我们用三进制来表示状态就可以了啊。
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <utility>
#include <algorithm>
#include <functional>
using namespace std;
const int maxn = 12;
const int inf  = 0x3f3f3f3f;


/* 由于每个节点最多走两次,因此我们采用三进制的方法来处理每个状态 */

int base[11];
int w[maxn][maxn];
int dp[59050][maxn];
int bit[59050][maxn];
int bcnt[59050];
int n, m;

void init() {
    base[0] = 1;
    for(int i = 1; i <= 10; ++i) {
        base[i] = base[i-1] * 3;
    }
    memset(bit, 0, sizeof(bit));
    memset(bcnt, 0, sizeof(bcnt));
    for(int i = 1; i <= base[10]; ++i) {
        int cnt = 0, t = i;
        while(t) {
            bit[i][cnt++] = t % 3;
            if(t%3) bcnt[i]++;
            t /= 3;
        }
    }
}


int main() {

    //freopen("aa.in", "r", stdin);

    init();
    int a, b, c;
    while(scanf("%d %d", &n, &m) != EOF) {
        memset(w, inf, sizeof(w));
        memset(dp, inf, sizeof(dp));
        for(int i = 0; i < m; ++i) {
            scanf("%d %d %d", &a, &b, &c);
            a--, b--;
            w[a][b] = min(w[a][b], c);
            w[b][a] = min(w[b][a], c);
        }
        for(int i = 0; i < n; ++i) {
            dp[base[i]][i] = 0;
        }
        for(int i = 1; i < base[n]; ++i) {
            for(int j = 0; j < n; ++j) {
                if(bit[i][j] == 0) continue;
                for(int k = 0; k < n; ++k) {
                    if(bit[i][k] > 0 && k != j && dp[i-base[j]][k] != inf) {
                        dp[i][j] = min(dp[i][j], dp[i-base[j]][k] + w[k][j]);
                    }
                }
            }
        }
        int ans = inf;
        for(int i = 1; i < base[n]; ++i) {
            if(bcnt[i] == n) {
                for(int j = 0; j < n; ++j) {
                    ans = min(ans, dp[i][j]);
                }
            }
        }
        if(ans >= inf) {
            printf("-1\n");
        } else {
            printf("%d\n", ans);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值