POJ - 3181 Dollar Dayz

 

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

思路:参考如下链接:https://blog.csdn.net/libin56842/article/details/9455979

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define mod 1000000000000000000
long long a[1010][110];//hou
long long b[1010][110];//qian
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=0; i<k; i++)
            a[i][0]=1;
        for(int i=1; i<=k; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(i>j)
                {
                    a[i][j]=a[i-1][j];
                    b[i][j]=b[i-1][j];
                }
                else
                {
                    a[i][j]=(a[i-1][j]+a[i][j-i])%mod;
                    b[i][j]=b[i-1][j]+b[i][j-i]+(a[i-1][j]+a[i][j-i])/mod;
                }
            }
        }
        if(b[k][n])
            printf("%lld%lld\n",b[k][n],a[k][n]);
        else
            printf("%lld\n",a[k][n]);
    }
    return 0;
}

 

使用一维数组写的,参考如下链接:https://www.cnblogs.com/kuangbin/archive/2012/09/20/2695165.html

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
const int MAXN=1100;
const long long inf=1000000000000000000LL;

long long a[MAXN];//高位
long long b[MAXN];//低位

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(a));
        b[0]=1;
        for(int i=1;i<=k;i++)
          for(int j=i;j<=n;j++)
          {
              a[j]=a[j]+a[j-i]+(b[j]+b[j-i])/inf;
              b[j]=(b[j]+b[j-i])%inf;
          }
        if(a[n]==0)
        {
            printf("%lld\n",b[n]);
        }
        else
        {
            printf("%lld%lld\n",a[n],b[n]);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值