Dollar Dayz POJ - 3181

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:

    1 @ US$3 + 1 @ US$2

    1 @ US$3 + 2 @ US$1

    1 @ US$2 + 3 @ US$1

    2 @ US$2 + 1 @ US$1

    5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of 1.. 1.. 1..K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

思路:

这个倒是没什么好说的,原本方法用01背包写,但是这里使可以无限使用的,需要用完全背包来结局,不过,要注意一下这是一道高精度的问题,小生也是看了一位大佬,才明白的,大佬写的在这个传送门

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<iomanip>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#define ll long long
#define mes(x,y) memset(x,y,sizeof(x))
#define mv 2147483648+30
using namespace std;
ll gcd (ll x, ll y ){
	return x % y == 0 ? y : gcd(y , x%y);
}
int addition(int x[],int y[])//高精度加法
{
    for(int i = 0 ; i < 100 ; i ++)
    {
        y[i] + = x[i];
        if( y[i] > 9 )
        {
            y[i+1] ++;
            y[i] - = 10 ;
        }
    }
    return *y;
}
int main() {
	int n , m ;
	while(cin >> n >> m){
	
	int dp[2000][100];
	
		int  i , j ; mes( dp , 0 );
		
		dp[0][0] = 1;
		
		for( i = 1 ; i <= m ; i++ )
		
			for( j = i ; j <= n ; j ++)
			
			*dp[j] = addition( dp[j-i] , dp[j] );
			
		i = 100;
		
		while ( i ) {
		
			if( dp[n][i] ) break;
			
			i --;
		}
		while(i>=0){
		
			cout << dp[n][i] ; i --;
			
		}
		
		cout << endl;
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GUESSERR

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值