HDU-1243 Greatest Common Increasing Subsequence

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题目大意:给出两个序列,求两个序列的最长公共上升子序列。

思路:根据最长上升子序列,和最长公共子序列的模板,当满足上升和相等的时候即为所求的。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[510],b[510];
int m,n;
int dp[510];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(dp,0,sizeof(dp));
        scanf("%d",&m);
        for(int i=0; i<m; i++)
            scanf("%d",&a[i]);
        scanf("%d",&n);
        for(int j=0; j<n; j++)
            scanf("%d",&b[j]);
        int ans=-1;
        for(int i=0; i<m; i++)
        {
            int maxx=0;
            for(int j=0; j<n; j++)
            {
                if(a[i]>b[j]&&dp[j]>maxx)//当满足上升的时候更新
                    maxx=dp[j];
                if(a[i]==b[j])
                    dp[j]=maxx+1;//当两个数字相等的时候才能加1
                ans=max(ans,dp[j]);
            }

        }
        printf("%d\n",ans);
        if(t)
            printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值