团体程序设计天梯赛 L2-006 树的遍历

L2-006 树的遍历

分数 25

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

题解

 根据中序遍历和后序遍历建立二叉树,用结构体储存,然后用bfs输出层序遍历。

#include<bits/stdc++.h>
using namespace std;
int n;
int mid[35];
int after[35];
struct node{
	int l,r;//左右子树
}t[35];
vector<int> ans;
int build(int l1,int l2,int r1,int r2)
{
	if(l1>l2) return 0;//树为空
	int root=after[r2];//标记根节点
	int p=l1;
    //寻找在中序遍历中的根节点
	while(mid[p]!=root)
	{
		p++;
	}
	int cnt=p-l1;
    //左右子树分别递归
	t[root].l=build(l1,p-1,r1,r1+cnt-1);
	t[root].r=build(p+1,l2,r1+cnt,r2-1);
	return root;
}
//bfs输出层序遍历
void bfs(int s)
{
	queue<int> q;
	q.push(s);
	
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		ans.push_back(u);
		if(t[u].l!=0)
		{
			q.push(t[u].l);
		}
		if(t[u].r!=0)
		{
			q.push(t[u].r);
		}
	}
}
int main()
{
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		cin>>after[i];
	}
	for(int i=1;i<=n;i++)
	{
		cin>>mid[i];
	}
	//int root=build(mid[1],mid[n],after[1],after[n]);
	int root=after[n];
	build(1,n,1,n);
	bfs(root);
	int cnt=0;
    //输出的时候注意最后一个不能有空格
	for(auto k:ans)
	{
		cnt++;
		if(cnt!=ans.size())
		{
			cout<<k<<" ";
		}
		else
		{
			cout<<k<<endl;
		}
	}
	return 0;
}

  • 9
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值