团体程序设计天梯赛 L2-011 玩转二叉树

L2-011 玩转二叉树

分数 25

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

题解 

根据前序和中序建立二叉树,因为是镜像,所以用BFS输出层序遍历,只是要从右孩子先输出。

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define endl '\n'
int n;
int mid[35];
int pre[35];
int v[35];
vector<int> ans;
struct node{
	
	int l=0,r=0;
}t[35];
//建立二叉树
int build(int l1,int l2,int r1,int r2)
{
	if(l1>l2) return 0;
	int root=pre[r1];

	int p=l1;
	while(mid[p]!=root)
	{
		p++;
	}
	int cnt=p-l1;
	t[root].l=build(l1,l1+cnt-1,r1+1,r1+cnt);
	t[root].r=build(p+1,l2,r1+cnt+1,r2);
	return root;
}
//搜索
void bfs(int root)
{
	queue<int> q;
	q.push(root);
	ans.push_back(root);
	v[root]=1;
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		if(t[u].r!=0)//镜像了 所以右孩子先
		{
			q.push(t[u].r);
			ans.push_back(t[u].r);
			v[t[u].r]=1;
		}
		if(t[u].l!=0)
		{
			q.push(t[u].l);
			ans.push_back(t[u].l);
			v[t[u].l]=1;
		}
	}
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	cout.tie(0);
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		cin>>mid[i];
	}
	for(int i=1;i<=n;i++)
	{
		cin>>pre[i];
	}
	build(1,n,1,n);
	bfs(pre[1]);
	int i=0;
	for(auto k:ans)
	{
		i++;
		if(i!=ans.size())
		{
			cout<<k<<" ";
		}
		else
		{
			cout<<k<<endl;//注意最后不要带空格
		}
	}
	return 0;
}

  • 6
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值