团体程序设计天梯赛 L2-012 关于堆的判断

L2-012 关于堆的判断

分数 25

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

题解 

边输入边建堆,然后根据堆的性质进行判断

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define endl '\n'
int n,m;
int t[1005];
int cnt;
map<int,int> ans;
//建堆
void build(int x)
{
	cnt++;
	t[cnt]=x;
	int temp=cnt;
	while(temp>1 && t[temp/2]>t[temp])
	{
		swap(t[temp/2],t[temp]);
		temp/=2;
	}
}
int main()
{
	ios::sync_with_stdio(0);
	cin.tie(0);
	cout.tie(0);
	cin>>n>>m;
	for(int i=1;i<=n;i++)
	{
		int x;
		cin>>x;
		build(x);
	}
	for(int i=1;i<=n;i++)
	{
		
		ans[t[i]]=i;//反向对应
	}
	while(m--)
	{
		int a;
		cin>>a;
		string s;
		cin>>s;
		if(s[0]=='i')
		{
			string ss;
			cin>>ss;
			string sss;
			cin>>sss; 
			if(sss[0]=='r')
			{
				if(a==t[1])
				{
					cout<<"T"<<endl;
				}
				else
				{
					cout<<"F"<<endl;
				}
			}
			else if(sss[0]=='p')
			{
				string ssss;
				cin>>ssss;
				int b;
				cin>>b;
				if(ans[a]==ans[b]/2)
				{
					cout<<"T"<<endl;
				}
				else
				{
					cout<<"F"<<endl;
				}
			}
			else if(sss[0]=='c')
			{
				string ssss;
				cin>>ssss;
				int b;
				cin>>b;
				if(ans[b]==ans[a]/2)
				{
					cout<<"T"<<endl;
				}
				else
				{
					cout<<"F"<<endl;
				}
			}
			
		}
		else if(s[0]=='a')
		{
			int b;
			cin>>b;
			string ss;
			cin>>ss;
			string sss;
			cin>>sss;
			if(ans[a]/2==ans[b]/2)
			{
				cout<<"T"<<endl;
			}
			else
			{
				cout<<"F"<<endl;
			}
		}
		
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值