PAT甲级(Advanced Level) 1002 A+B for Polynomials

1002 A+B for Polynomials

分数 25

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目概述

 题目要求你计算两个多项式 A和

对于每个测试用例,你应该在一行中输出 A 和 B 的和,格式与输入相同。注意,每行末尾不能有多余的空格。请保留一位小数的精度。

题解

思路较为简单,用map来储存每个项对应的数,每次将其累加即可。

注意点一:要保留一位小数

注意点二:可能某一项会被消掉,此时不能输出

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define endl '\n'
map<int,double> a;
set<int,greater<int> > s;
int main()
{
	for(int i=1;i<=2;i++)
	{
		int k;
		cin>>k;
		for(int j=0;j<k;j++)
		{
			int key;
			double value;
			cin>>key>>value;
			a[key]+=value;
			s.insert(key);
		}
	}
	int op=0;
    int len=0;
    for(auto k:s)
    {
        if(a[k]!=0)
        {
            len++;
        }
    }
    if(len==0)
    {
        cout<<0;
        return 0;
    }
	cout<<len<<" ";
	for(auto k:s)
	{
        if(a[k]==0) continue;
		op++;
		if(op!=len)
		{
			cout<<k<<" "<<fixed<<setprecision(1)<<a[k]<<" ";
		}
		else
		{
			cout<<k<<" "<<fixed<<setprecision(1)<<a[k]<<endl;
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值