PAT甲级——Integer Factorization

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

思路:这道题考察的是深度优先搜索的知识。

步骤一:建立一个fac数组,用来存储从1到某个数x的平方,x的平方小于等于n;

步骤二:建立DFS函数,几个重要的参数有index(当前处理到的是fac的几号位),当前已经选择了几个数nowK,当前选出的数的和sum,当前的底数之和facSum。

步骤三:让index从较大的数开始遍历,这样就能选中fac中较大的数了

步骤四:递归停止的条件,sum==N且nowk==k成立,那么说明找到了一个满足条件的序列,这个时候还要判断多种结果的情况,若facSum大于maxFacSum则更新后者。除此之外,当sum>N或者nowk>k时可能不会产生答案,可以直接返回。

代码:

#include <iostream>
#include<vector>
#include<algorithm>
using namespace std;

int n, k, p, maxFacSum = -1;
vector<int>temp, fac, ans;

//计算x^p
int power(int x)
{
	int answer = 1;
	for (int i = 0; i < p; i++)
	{
		answer *= x;
	}
	return answer;
}

//init()预处理数组fac
void init()
{
	int i = 0, answer = 0;
	while (answer<=n)
	{
		fac.push_back(answer);
		answer = power(++i);
	}
}

void DFS(int index,int nowK,int sum,int facSum)
{
	if (nowK == k && sum == n)
	{
		if (facSum > maxFacSum)
		{
			ans = temp;
			maxFacSum = facSum;
		}
		return;
	}

	if (sum > n || nowK > k) return;
	if (index - 1 >= 0)
	{
		temp.push_back(index);
		DFS(index, nowK + 1, sum + fac[index], facSum + index);
		temp.pop_back();
		DFS(index - 1, nowK, sum, facSum);

	}


}

int main()
{
	scanf("%d%d%d", &n, &k, &p);
	init();
	DFS(fac.size() - 1, 0, 0, 0);
	if (maxFacSum == -1) printf("Impossible\n");
	else {
		printf("%d = %d^%d", n, ans[0], p);
		for (int i = 1; i < ans.size(); i++)
		{
			printf(" + %d^%d", ans[i], p);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值