PAT - 甲级 - 1103. Integer Factorization (30)(dfs回溯+减枝)

题目描述:

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to belarger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

题目思路:

递归搜索出所有的情况(注意减枝),输出数字和最大的一组即可。

题目代码:

#include <cstdio>
#include <vector>
#include <cmath>
using namespace std;
int n, k, p;
int ans[405];
int sum = 0,cnt = 0;
vector<int>v[100000];  
void dfs(int cur, int num){
	// 退出条件 
	if(sum > n || cur > k) return ;	
	if(sum == n){  
		if(cur == k){ // 符合条件的结果			
			for(int i = 0; i < cur; i++){
				v[cnt].push_back(ans[i]);
			}		
			cnt++;
			return ;
		}
	}
	// 递归范围 
	for(int i = num; i >=1 ;i--){
		int temp = 1;
		for(int j = 0; j < p; j++){
			temp *= i;
		}
		ans[cur] = i;
		sum += temp;
		dfs(cur+1, i);
		sum -= temp; // 回溯	
	}	
}
int main(){
	scanf("%d%d%d",&n,&k,&p);
	dfs(0,sqrt(n));
	// 如果符合条件的结果数为0, impossible 
	if(cnt == 0){
		printf("Impossible\n"); 
	}else{
		// 记录和最大的一组答案的编号 
		int maxid, maxsum = -1;
		for(int i = 0; i < cnt; i++){
			int cursum = 0;
			for(int j = 0; j <v[i].size(); j++){
				cursum += v[i][j];
			}
			if(cursum > maxsum){
				maxsum = cursum;
				maxid = i;
			} 
		}
		// 答案输出 
		printf("%d = ",n);
		for(int i = 0; i < v[maxid].size(); i++){
			if(i)printf(" + ");
			printf("%d^%d",v[maxid][i],p);
		}
	}	
	return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值