PAT甲级——Head of a Gang

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then Nlines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

思路:

步骤一:首先用map<string,int>和map<int,string>解决姓名字符串和整型编号的关系 

步骤二:获得每个人的点权,即与之相关的通话记录的时长之和,这可以在读入的时候进行处理(假设A与B的点权分别增加T)。事实上,该步是在求与某个点相连的边的边权之和。

步骤三:进行图的遍历。使用DFS遍历每个连通块,目的是获取每个连通块的头目(即连通块内点权最大的结点)、成员的个数、总边数。

步骤四:通过步骤三可以获得连通块的总边权totalValue。如果totalValue大于给定的阈值K,且成员人数大于2,说明该连通块是个团伙,将该团伙的信息储存下来。

代码:

#include <iostream>
#include<string>
#include<map>
using namespace std;
const int maxn = 2010;//总人数
const int INF = 1000000000;//无穷大

map<int, string>intToString;//编号->姓名
map<string, int>stringToInt;//姓名->编号
map<string, int>Gang;//head->人数

int G[maxn][maxn] = { 0 }, weight[maxn] = { 0 };//邻接矩阵G,点权weight
int n, k, numPerson = 0;//边数n,下限k,总人数numPerson
bool vis[maxn] = { false };//标记是否被访问

//DFS函数访问单个连通块,nowVisit为连通块的总边权
void DFS(int nowVisit, int& head, int& numMember, int& totalValue) {
	numMember++;
	vis[nowVisit] = true;//标记nowVisit已访问
	if (weight[nowVisit] > weight[head]) {
		head = nowVisit;//当前访问结点的点权大于头目的点权,则更新头目
	}
	for (int i = 0; i < numPerson; i++) {
		if (G[nowVisit][i] > 0) {//如果从nowVisit能到达i
			totalValue += G[i][nowVisit];//连通块的总边权增加该边权
			G[nowVisit][i] = G[i][nowVisit] = 0;//删除这条边,防止回头
			if (vis[i] == false) {//如果i未被访问,则递归访问i
				DFS(i, head, numMember, totalValue);
			}
		}
	}
}

//DFSTrave函数遍历整个图,获取每个连通块的信息
void DFSTravel() {
	for (int i = 0; i < numPerson; i++) {
		if (vis[i] == false) {//如果i未被访问
			int head = i, numMember = 0, totalValue = 0;//头目、成员数、总边数
			DFS(i, head, numMember, totalValue);
			if (numMember > 2 && totalValue > k) {
				Gang[intToString[head]] = numMember;
			}
		}
	}
}

//change函数返回姓名str对应的编号
int change(string str) {
	if (stringToInt.find(str) != stringToInt.end()) {
		return stringToInt[str];//返回编号
	}
	else {
		stringToInt[str] = numPerson;//str的编号为numPerson
		intToString[numPerson] = str;//numPerson对应str
		return numPerson++;//总人数加一
	}
}
int main()
{
	int w;
	string str1, str2;
	cin >> n >> k;
	for (int i = 0; i < n; i++)
	{
		cin >> str1 >> str2 >> w;
		int id1 = change(str1);//将str1转化为编号id1
		int id2 = change(str2);
		weight[id1] += w;
		weight[id2] += w;
		G[id1][id2] += w;
		G[id2][id1] += w;
	}
	DFSTravel();//遍历整个图的所有连通块,获取Gang的信息
	cout << Gang.size() << endl;
	map<string, int>::iterator it;
	for (it = Gang.begin(); it != Gang.end(); it++) {
		cout << it->first << " " << it->second << endl;
	}
	return 0;
}

复习:

       这道题还是有点复杂的,首先要想着怎么将给出的字符串的名字映射为数字,用哈希的方法是可以,但是好像有点麻烦,这里用映射的方式更方便,而且序号都是从0开始,一个挨着一个便于后面处理数据。还有就是点权和边权的记录,都是累加的,但是记录边权的时候要注意,不能重复地相加,加过一次之后要清空G里面对应的两个边权。还有连通体成员数目的记录也不能忘了。这里的DFS是要找出所有的连通体,所以要对每个没有被访问过的点都进行DFS,之前查找路径只需要从一个点开始查找就行了。

二刷代码:

#include <iostream>
#include<map>
#include<string>

using namespace std;
const int maxn = 2010;



map<int, string>intToString;
map<string, int>StringToInt;
map<string, int>Gang;//head->人数
int G[maxn][maxn] = { 0 }, weight[maxn] = { 0 };
int n, k, numPerson = 0;//边数n,下限k,总人数numPerson
bool vis[maxn] = { false };

void DFS(int nowVisit, int &head, int&numMember, int& totalValue) {
	numMember++;
	vis[nowVisit] = true;
	if (weight[nowVisit] > weight[head]) {
		head = nowVisit;
	}
	for (int i = 0; i < numPerson; i++)
	{
		if (G[nowVisit][i] > 0)
		{
			totalValue += G[nowVisit][i];
			G[nowVisit][i] = G[i][nowVisit] = 0;
			if (vis[i] == false) {
				DFS(i, head, numMember, totalValue);
			}
		}
	}
}

void DFSTrave()
{
	for (int i = 0; i < numPerson; i++)
	{
		if (vis[i] == false)
		{
			int head = i, numMember = 0, totalValue = 0;
			DFS(i, head, numMember, totalValue);
			if (numMember > 2 && totalValue > k) {
				Gang[intToString[head]] = numMember;
			}
		}
	}
}

int change(string str)
{
	if (StringToInt.find(str) != StringToInt.end())
		return StringToInt[str];
	else {
		StringToInt[str] = numPerson;
		intToString[numPerson] = str;
		return numPerson++;
	}
	
}

int main()
{
	int w;
	string str1, str2;
	cin >> n >> k;
	for (int i = 0; i < n; i++)
	{
		cin >> str1 >> str2 >> w;
		int id1 = change(str1);
		int id2 = change(str2);
		weight[id1] += w;
		weight[id2] += w;
		G[id1][id2] += w;
		G[id2][id1] += w;
	}
	DFSTrave();
	cout << Gang.size() << endl;
	map<string, int>::iterator it;
	for (it = Gang.begin(); it != Gang.end(); it++)
	{
		cout << it->first << " " << it->second << endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值