PAT甲级——Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

思路: 这里一开始看到题有点懵,只知道这道题可能蕴含中序遍历序列,但是只有中序遍历序列是无法重建一棵二叉树的。其实,仔细模拟一下样例给的入栈出栈的过程可以发现,入栈总是从根节点开始,到左子树,再到右子树,体现的先序遍历过程。出栈总是从左子树到根节点再到右节点,体现的是中序遍历的过程,于是就可以使用模板来利用这两个序列重建二叉树,然后进行后序遍历输出结果即可。

注意:写递归函数的时候千万检查不能掉了递归边界,这里很容易漏掉,还有模拟入栈和出栈的过程操作次数是2n次,很容易惯性地认为是n次。前面的push和pop的判断可以用字符串比较函数strcmp非常好用,我一开始就很苦恼这个数据到底该怎么输入。

#include <iostream>
#include<stack>
#include<algorithm>
#include<cstring>
using namespace std;
const int maxn = 35;

int pre[maxn], in[maxn],n;

struct node {
	int data;
	node* lchild;
	node* rchild;
};

//先序和中序建树
node* create(int preL, int preR, int inL, int inR)
{
	if (preL > preR)  return NULL;//递归千万不能掉边界条件
	node* root = new node;
	root->data = pre[preL];
	int k;
	for (k = inL; k <= inR; k++)
	{
		if (in[k] == pre[preL]) break;
	}
	int numleft = k - inL;
	root->lchild = create(preL + 1, preL + numleft, inL, k - 1);
	root->rchild = create(preL + numleft + 1, preR, k + 1, inR);
	return root;
}

//后序遍历
int num = 0;
void pos_travel(node* root)
{
	
	if (root == NULL) return;
	pos_travel(root->lchild);
	pos_travel(root->rchild);
	printf("%d", root->data);
	num++;
	if (num<n) printf(" ");
}

int main()
{
	scanf("%d", &n);
	char str[5];
	stack<int>st;
	int pre_index = 0, in_index = 0,x;
	for (int i = 0; i < 2*n; i++)//出栈和入栈一共是2n次 千万别错了
	{
		scanf("%s", str);
		if (strcmp(str, "Push") == 0) {
			scanf("%d", &x);
			st.push(x);
			pre[pre_index++] = x;

		}
		else {
			in[in_index++] = st.top();
			st.pop();
		}
	}
	node* now=create(0, n - 1, 0, n - 1);
	pos_travel(now);
	return 0;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值