PAT (Advanced Level) 1086 Tree Traversals Again (25 分)

1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

Code:

#include <iostream>
#include <stack>
#include <vector>
#pragma warning(disable:4996)

using namespace std;

vector<int> pre, in, pos;

void postOrder(int preL, int preR, int inL, int inR)
{
	if (preL >= preR)
		return;
	int k = inL;
	while (k < inR && in[k] != pre[preL]) k++;
	postOrder(preL + 1, preL + 1 + k - inL, inL, k);
	postOrder(preL + 1 + k - inL, preL - inL + inR, k + 1, inR);
	pos.push_back(pre[preL]);
}

int main()
{
	int n;
	scanf("%d", &n);
	stack<int> st;
	for (int i = 0; i < 2 * n; i++)
	{
		char s[5];
		scanf("%s", s);
		if (strlen(s) == 4)
		{
			int num;
			scanf("%d", &num);
			pre.push_back(num);
			st.push(num);
		}
		else
		{
			in.push_back(st.top());
			st.pop();
		}
	}
	postOrder(0, n, 0, n);
	for (int i = 0; i < pos.size(); i++)
		printf("%d%c", pos[i], (i == pos.size() - 1 ? '\n' : ' '));
	return 0;
}

思路:

压栈的顺序是先根遍历的顺序,出栈的顺序是中序遍历的顺序,因此题目划归为知先序中序遍历求后序遍历。
膜柳神 https://blog.csdn.net/liuchuo/article/details/52181237

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值