A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.
Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.
Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.
Input Specification:
Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N−1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:
Ki ID[1] ID[2] ... ID[Ki]
where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.
Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2
思路: 这道题其实就是寻找层次最小的叶子结点的个数,因为经过的结点数越少,中间商就越少赚差价,这样的价格是最便宜的。用DFS做的话,只需要在每条路径的最后计算单价,然后更新最小单价即可,还需要设置一个变量来统计相同价位经销商的个数。用BFS来做,一定要记得不是寻找layer最低的结点,而是在叶子结点中寻找layer的最小值,在这个问题上绕了很久。
代码:
//BFS版
#include <iostream>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 100010;
int n,num,test;
double r, p,min_price=1000000000,ans;
struct node {
vector<int>child;
}Node[maxn];
void DFS(int index, int depth)
{
if (Node[index].child.size() == 0)
{
ans = p*pow(1 + r, depth);
//printf_s("%d %f\n", depth,ans);
if (ans < min_price) {
min_price = ans;
num =1;
}
else if (ans == min_price) {
num++;
}
return;
}
for (int i = 0; i < Node[index].child.size(); i++)
{
DFS(Node[index].child[i], depth + 1);
}
}
int main()
{
scanf("%d%lf%lf", &n, &p, &r);
r = r / 100;
int k ,child;
for (int i = 0; i < n; i++)
{
scanf("%d", &k);
if (k != 0) {
for (int j = 0; j < k; j++)
{
scanf("%d", &child);
Node[i].child.push_back(child);
}
}
}
DFS(0, 0);
printf("%.4f %d", min_price,num);
return 0;
}
//BFS版
#include <iostream>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 100010;
int n,num=0,temp,final_layer = 1000000000;
double r, p,ans;
struct node {
vector<int>child;
int layer;
}Node[maxn];
/*
void DFS(int index, int depth)
{
if (Node[index].child.size() == 0)
{
ans = p*pow(1 + r, depth);
//printf_s("%d %f\n", depth,ans);
if (ans < min_price) {
min_price = ans;
num =1;
}
else if (ans == min_price) {
num++;
}
return;
}
for (int i = 0; i < Node[index].child.size(); i++)
{
DFS(Node[index].child[i], depth + 1);
}
}
*/
void BFS(int index)
{
queue<int>Q;
Q.push(index);
while (!Q.empty())
{
int now = Q.front();
Q.pop();
if (Node[now].child.size() != 0) {
for (int i = 0; i < Node[now].child.size(); i++) {
int temp = Node[now].child[i];
Q.push(temp);
Node[temp].layer = Node[now].layer + 1;
}
}
}
}
int main()
{
//printf_s("%d\n", max_layer);
scanf("%d%lf%lf", &n, &p, &r);
r = r / 100;
int k ,child;
for (int i = 0; i < n; i++)
{
Node[i].layer = 0;
}
for (int i = 0; i < n; i++)
{
scanf("%d", &k);
if (k != 0) {
for (int j = 0; j < k; j++)
{
scanf("%d", &child);
Node[i].child.push_back(child);
}
}
}
BFS(0);
for (int i = 0; i < n; i++)
{
if (Node[i].child.size() == 0) {
if (Node[i].layer < final_layer) {
final_layer = Node[i].layer;
//printf_s("%d\n", max_layer);
num = 1;
}
else if (Node[i].layer == final_layer) {
num++;
}
}
}
ans = p * pow(1 + r, final_layer);
//printf_s("%f %f %f\n", p, r, p*(1 + r)*(1 + r)*(1 + r));
printf("%.4f %d\n", ans,num);
return 0;
}