PAT甲级——1018 Public Bike Management

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

思路: 

       这道题需要好好理清一下思路。首先是找到从图中起点到问题结点的最短路径,这样的最短路径可能有好几条,我们要找出的是从起点携带的自行车最少数目的路线,如果从起点携带的自行车最少的数目也相同,那么就选择从从问题结点带回去的最少的自行车的路线。前面选最短路径可以用Dijstra方法,但是要选择最优路径还得加上DFS方法来计算所需要带过去和带回来的自行车的数目,以此为依据来选择最优路径。

代码:

#include <iostream>
#include<vector>
#include<algorithm>
using namespace std;
const int MAXV = 510;//最大顶点数
const int INF = 1000000000;//无穷大

//n为顶点数,m为边数,Cmax为最大容量,Sp为问题站点
//G为领接矩阵,weight为点权,d[]记录最短距离
//minNeed记录最少携带的数目,minRemain记录最少带回的数目
int n, m, Cmax, Sp, numPath = 0, G[MAXV][MAXV], weight[MAXV];
int d[MAXV], minNeed = INF, minRemain = INF;
bool vis[MAXV] = { false };
vector<int>pre[MAXV];//前驱
vector<int>tempPath, Path;//临时路径以及最优路径

void Dijkstra(int s)//s为起点
{
	fill(d, d + MAXV, INF);
	d[s] = 0;
	for (int i = 0; i < n; i++)
	{
		int u = -1, MIN = INF;
		for (int j = 0; j < n; j++)//找到未访问的顶点中的d[i]最小的
		{
			if (vis[j] == false && d[j] < MIN)
			{
				u = j;
				MIN = d[j];
			}
		}
		//找不到小于INF的的d[u]说明剩下的顶点和起点s不连通
		if (u == -1) return;
		vis[u] = true;
		for (int v = 0; v <= n; v++)
		{
			//如果v未访问&&u能到达v
			if (vis[v] == false && G[u][v] != INF)
			{
				if (d[u] + G[u][v] < d[v])
				{
					d[v] = d[u] + G[u][v];//优化d[v]
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if (d[u] + G[u][v] == d[v]) {
					pre[v].push_back(u);
				}
			}
		}
	}
}

void DFS(int v)
{
	//printf_s("运行到这里");
	if (v == 0) {//递归边界,叶子结点
		tempPath.push_back(v);
		//路径tempPath上需要携带的数目、需要带回的数目
		int need = 0, remain = 0;
		for (int i = tempPath.size() - 1; i >= 0; i--)//这里要倒着枚举
		{
			int id = tempPath[i];
			if (weight[id] > 0)//点权大于0说明需要带走一部分自行车
			{
				remain += weight[id];//当前自行车持有量增加weight[id]
			}
			else {
				if (remain > abs(weight[id])) {//当前持有量足够补给
					remain -= abs(weight[id]);
				}
				else {//当前持有量不够补给
					need += abs(weight[id])-remain;//不够的部分从PBMC携带
					remain = 0;//当前持有的自行车全部用来补给
				}
			}
			//intf_s("运行到这里\n");

		}
		if (need < minNeed)//需要从PBMC携带的自行车数目更少
		{
			minNeed = need;
			minRemain = remain;
			Path = tempPath;
		}
		else if (need == minNeed && remain < minRemain) {
			//携带数目相同,带回数目变少
			minRemain = remain;
			Path = tempPath;
			//printf_s("运行到这里");
		}
		tempPath.pop_back();
		
		return;
	}
	tempPath.push_back(v);
	for (int i = 0; i < pre[v].size(); i++)
	{
		DFS(pre[v][i]);
	}
	tempPath.pop_back();
}




int main()
{
	scanf("%d%d%d%d", &Cmax, &n, &Sp, &m);
	int u, v;
	fill(G[0], G[0] + MAXV * MAXV, INF);//初始化图
	for (int i = 1; i <= n; i++)
	{
		scanf("%d", &weight);
		weight[i] -= Cmax / 2;//点权减去容量的一半
	}
	for (int i = 0; i < m; i++)
	{
		scanf("%d%d", &u, &v);
		scanf("%d", &G[u][v]);
		G[u][v] = G[v][u];
	}
	Dijkstra(0);
	DFS(Sp);
	printf("%d ", minNeed);
	//printf("%d", Path.size());
	for (int i = Path.size() - 1; i >= 0; i--)
	{
		printf_s("%d", Path[i]);
		if (i > 0) printf("->");
	}
	printf(" %d", minRemain);
	return 0;
}

 

复习: 

         这道题的代码量还挺多的,首先要知道Dijkstra算法求的是起点0到其他节点的最短距离,可以在这个过程中记录最短路径的条数,但是附加了题目中的携带量和带回量的计算要求,就需要先求出距离最短且相等的每一条路径,然后再计算这些值,光靠这个算法是实现不了的。Dijkstra算法可以在遍历图的过程中记录一下每个节点的前驱节点,在这之后,我们需要从问题节点出发进行DFS,每次遍历完一条路径就计算携带量和带回量两个指标,并且将两个值都较小的路径作为最后选择的路径。在写DFS算法的时候要注意元素的及时取出,也就是在遍历完一条路径后就将它的节点信息删除掉。还有就是未初始化的全局数组和静态数组会默认初始化为0,比如weight[MAXV]。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值