PAT甲级——1072 Gas Station

A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10​3​​), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10​4​​), the number of roads connecting the houses and the gas stations; and D​S​​, the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist

where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:

For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:

4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2

Sample Output 1:

G1
2.0 3.3

Sample Input 2:

2 1 2 10
1 G1 9
2 G1 20

Sample Output 2:

No Solution

思路: 

步骤1:首先要解决顶点的编号问题,对于居民房来说,输入的编号就是它的编号;对加油站来说,输入的编号去掉最前面的‘G’后就是它的编号,但是为了和居民房区分,需要把加油站的编号加上居民房的个数来作为加油站的编号。例如,如果有5个居民房,3个加油站,那么居民房的编号就是1~5,加油站的编号就是6~8,可以用字符串开头的G来判断是否是加油站或者居民房。

步骤2:枚举每个加油站,用Dijkstra算法得到所有居民房距离该加油站的最短距离。要注意的是,所有的加油站也需要作为实际的顶点参与Dijkstra算法的计算。在得到某个加油站的数组的d[MAXV]后,需要获取其中最小的元素(即该加油站与居民房的最近距离)及计算所有居民房(1~n)与加油站的平均距离,过程中如果出现某个d[i]大于DS,则说明存在居民房与该待选加油站的距离超过了服务范围,该待选的加油站不合格。接下来,如果最近的距离比当前最大的最近距离还大,则更新最大的最近距离;如果最近距离相同,则更新最小的平均距离。

代码:

#include <iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXV = 1020;//最大顶点数
const int INF = 1000000000;//无穷大

int n, m, k, DS, G[MAXV][MAXV];//n为顶点数,m为加油站数目,k为边数,DS为服务范围,G为邻接矩阵
int d[MAXV];//d[]记录最短距离
bool vis[MAXV] = { false };

void Dijksra(int s)
{
	memset(vis, false, sizeof(vis));
	fill(d, d + MAXV, INF);
	d[s] = 0;
	for (int i = 0; i < n + m; i++)
	{
		int u = -1,MIN = INF;
		for (int j = 1; j <=m+n; j++)
		{
			if (vis[j] == false && d[j] < MIN)
			{
				u = j;
				MIN = d[j];
			}
		}
		if (u == -1) return;
		vis[u] = true;
		for (int v = 1; v <= n + m; v++)
		{
			if (vis[v] == false && G[u][v] != INF)
			{
				if (d[u] + G[u][v] < d[v]) {
					d[v] = d[u] + G[u][v];
				}
			}
		}

	}
	

}

int getID(char str[])
{
	int len = strlen(str), i = 0, ID = 0;
	while (i<len)
	{
		if (str[i] != 'G')
		{
			ID = ID * 10 + (str[i] - '0');
		}
		i++;
	}
	if (str[0] =='G') return ID+n;
	else return ID;
}

int main()
{
	scanf("%d%d%d%d", &n, &m, &k, &DS);
	int u, v, w;
	char city1[5], city2[5];
	fill(G[0], G[0] + MAXV * MAXV, INF);
	for (int i = 0; i < k; i++)
	{
		scanf("%s %s %d", city1, city2, &w);
		u = getID(city1);
		v = getID(city2);
		G[u][v] = G[v][u] = w;
	}
	//ansDis存放使最大的最短距离
	//ansAvg存放最小平均距离,ansID存放最终加油站ID
	double ansDis = -1, ansAvg = INF;
	int ansID = -1;
	for (int i = n + 1; i <= m + n; i++)
	{
		double minDis = INF, avg = 0;//minDis为最大的最近距离,avg为平均距离
		Dijksra(i);
		for (int j = 1; j <= n; j++)
		{
			if (d[j] > DS)
			{
				minDis = -1;//这里不要掉
				break;
			}
			if (d[j] < minDis) 
				minDis = d[j];
			avg += 1.0*d[j] / n;
			
		}
		if (minDis == -1) continue;
		if (minDis > ansDis) {
			ansID = i;
			ansDis = minDis;
			ansAvg = avg;
		}
		else if (minDis == ansDis && avg < ansAvg)
		{
			ansID = i;
			ansAvg = avg;
		}

	}
	if (ansID == -1) printf("No Solution\n");
	else {
		printf("G%d\n", ansID - n);
		printf("%.1f %.1f\n", ansDis, ansAvg);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值