Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
思路: 32与321按照字典序来排是32321,但是32132会更小。这里我们调整一下字符串数组排序的思路,即按照a+b<b+a来排序,利用sort函数就可以将数组排好序。完成字符串的拼接后,最后的结果需要将前面的0删除。
函数erase():srt.erase(it)用于删除单个元素,it为需要删除元素的迭代器,比如str.erase(str.begin()+4;再来看srt.erase(first,last),其中first为所需要删除的区间的起始迭代器,而last则为需要删除的区间的末尾迭代器的下一个地址,也即为删除[first,last)。
#include <iostream>
#include<algorithm>
#include<cstdio>
#include<string>
using namespace std;
const int maxn = 10010;
bool cmp(string a, string b) {
return a + b < b + a;
}
int main()
{
string str[maxn];
int n;
//canf_s("%d", &n);
cin >> n;
for (int i = 0; i < n; i++)
{
//scanf_s("%s", &str[i]);
cin >> str[i];
}
sort(str, str + n,cmp);
string ans;
for (int i = 0; i < n; i++)
{
ans += str[i];
}
while (ans.size()!=0&&ans[0]=='0')
{
ans.erase(ans.begin());
}
if (ans.size() == 0) cout << 0;
else cout << ans;
return 0;
}