题目
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104 ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
AC代码
#include<bits/stdc++.h>
using namespace std;
bool cmp(string x,string y){
string xy=x+y,yx=y+x;
return xy<yx;
}
int main()
{
int n,len;
cin>>n;
string s[n];
for(int i=0;i<n;i++)
{
cin>>s[i];
len+=s[i].length();
}
sort(s,s+n,cmp);
string ans="";
for(int i=0;i<n;i++)
ans+=s[i];
stringstream ss;
int t;
ss<<s[n-1];
ss>>t;
if(t==0)
{
cout<<0;
return 0;
}
int flag=1;
for(int i=0;i<ans.length();i++)
{
if(flag&&ans[i]=='0') continue;
else flag=0;
cout<<ans[i];
}
}
参考
Recover the Smallest Number (30) - 字符串排序
知识点总结
- stringstream的相关用法
- 字符串排序