PAT——Recover the Smallest Number

Recover the Smallest Number

题目

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​ ) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

AC代码

#include<bits/stdc++.h>
using namespace std;

bool cmp(string x,string y){
	string xy=x+y,yx=y+x;
	return xy<yx;
}

int main()
{
	int n,len;
	cin>>n;
	string s[n];
	for(int i=0;i<n;i++)
	{
		cin>>s[i];
		len+=s[i].length();
	}
	sort(s,s+n,cmp);
	string ans="";
	for(int i=0;i<n;i++)
	ans+=s[i];
	stringstream ss;
	int t;
	ss<<s[n-1];
	ss>>t;
	if(t==0)
	{
		cout<<0;
		return 0;
	}	
	int flag=1;
	for(int i=0;i<ans.length();i++)
	{
		if(flag&&ans[i]=='0') continue;
		else flag=0;
		cout<<ans[i];
	}
}

参考

Recover the Smallest Number (30) - 字符串排序

知识点总结

  1. stringstream的相关用法
  2. 字符串排序
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值