PAT甲级——Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

思路:

  • 首先按照大整数乘法的通用模板求出输入值的2倍
  • 在定义count数组来统计两个数中各个数字的个数,比较它们的数量是否相等

代码:

#include<cstring>
using namespace std;

struct bign
{
	int d[21];
	int len;
	bign(){
		memset(d, 0, sizeof(d));
		len = 0;
	}
};

bign chang(char str[])
{
	bign a;
	a.len = strlen(str);
	for (int i = 0; i < a.len; i++)
	{
		a.d[i] = str[a.len - i - 1] -'0';
	}
	return a;
}

bign multi(bign a, int b)
{
	bign c;
	int carry = 0;
	for (int i = 0; i < a.len; i++)
	{
		int temp = a.d[i] * b+carry;
		c.d[c.len++] = temp % 10;//这里要写c.len++别写错了
		carry = temp / 10;
	}
	while (carry!=0)//这里和加法不一样,乘法的进位可能不止1位,因此用while
	{
		c.d[c.len++] = carry % 10;
		carry /= 10;
	}
	return c;
}

bool judge(bign a, bign b)
{
	if (a.len != b.len) return false;
	int count[10] = { 0 };
	for (int i = 0; i < a.len; i++)
	{
		count[a.d[i]]++;
		count[b.d[i]]--;
	}
	for (int i = 0; i < 10; i++)
	{
		if (count[i] != 0) return false;
	}
	return true;
}

void print(bign a)
{
	for (int i = a.len - 1; i >= 0; i--)
	{
		printf("%d", a.d[i]);
	}
}

int main()
{
	char str[21];
	scanf("%s", str);
	bign a = chang(str);
	bign b = multi(a, 2);
	bool flag = judge(a, b);
	if (flag == false) printf("No\n");
	else {
		printf("Yes\n");
	}
	print(b);
	return 0;


}

思路:

       大数计算问题可以按照通用的模板来做,大数输入的时候用字符数组存放,这个时候数组的左边放的是数的高位,数组的右边放的是数组的低位。然后定义一个结构体变量来存放数组的信息,首先用整型数组重新存储输入的数字信息,并且数组的左边放的是数字的低位,与字符串数组的顺序相反,然后用len来存储数组的长度。然后进行计算操作之后,对结果进行判断,如果计算前后两个数组的长度不一样,那么返回的肯定是false。

二刷代码:

#include <iostream>
#include<cstring>
using namespace std;

struct  bign
{
	int d[21];
	int len;
	bign()
	{
		memset(d, 0, sizeof(d));
		len = 0;
	}

};

bign change(char str[])
{
	bign a;
	a.len = strlen(str);
	for (int i = 0; i < a.len; i++)
	{
		a.d[i] = str[a.len - i - 1]-'0';
	}
	return a;
}


bign multi(bign a, int b)
{
	bign c;
	int carry = 0;//进位
	for (int i = 0; i < a.len; i++)
	{
		int temp = a.d[i] * b+ carry;
		c.d[c.len++] = temp % 10;//c.d[c.len++]这个写法要比c.d[i]好,下面判断最高位进位的时候有用
		carry = temp / 10;
	}
	while (carry!=0)
	{
		c.d[c.len++] = carry % 10;
		carry = carry / 10;
	}
	return c;

}

bool Judge(bign a, bign b)
{
	if (a.len != b.len)
		return false;
	int count[10] ={0};
	for (int i = 0; i < a.len; i++)
	{
		count[a.d[i]]++;
		count[b.d[i]]--;
	}
	for (int i = 0; i < 10; i++)
	{
		if (count[i] != 0)
			return false;
	}
	return true;
}

void print(bign a)
{
	for (int i = a.len-1; i >=0; i--)
	{
		printf("%d", a.d[i]);
	}
}

int main()
{
	char str[21];
	scanf("%s", str);
	bign a = change(str);
	bign mul = multi(a, 2);
	if (Judge(a, mul) == true) printf_s("Yes\n");
	else printf("No\n");
	print(mul);
	return 0;


}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值