PAT (Advanced Level) Practice 1023 Have Fun with Numbers(20分)【字符串】

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题意

判断一个整数乘2后的值是否是原来的数值的各位数字的一个排列。

代码

#include <iostream>
#include <string>

using namespace std;

int cnt[500];

int main() {
    string s1, s2;
    cin >> s1;
    s2 = s1;

    int carry = 0;
    for (auto i = s2.rbegin(); i != s2.rend(); ++i) {
        int d = (*i - '0') * 2 + carry;
        *i = d % 10 + '0';
        carry = d / 10;
    }
    if (carry != 0)
        s2.insert(s2.begin(), carry + '0');

    for (auto i = s1.begin(); i != s1.end(); ++i)
        cnt[*i]++;
    for (auto i = s2.begin(); i != s2.end(); ++i)
        cnt[*i]--;

    bool j = true;
    for (auto i = '0'; i <= '9'; ++i) {
        if (cnt[i] != 0) {
            j = false;
            break;
        }
    }

    cout << (j ? "Yes" : "No") << "\n" << s2;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值