PAT甲级——Mars Numbers

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earth is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

思路:考虑到输入的字符串可能是数字串也可能是字母串,所以要建立数字到火星文和火星文到数字的两个映射。由数字到火星文的映射,可以定义一个string数组,用数字索引对应相应的火星文;由火星文到数字的映射需要建立一个map映射。注意输入的数据都是字符串的形式,也就是说如果输入的是字符串里面都是数字,我们需要将它转化为int型的数字用于索引映射的关系。 

注意点:

  • map建立字符串到整型的映射只能用string而不能用char数组;
  • 在读入数据的时候,用的是getline,它可以完整读入一整行的内容,包括前导和嵌入的空格,并将其存储在字符串对象中,当 cin 读取数据时,它会传递并忽略任何前导白色空格字符(空格、制表符或换行符)。一旦它接触到第一个非空格字符即开始阅读,当它读取到下一个空白字符时,它将停止读取。
  • 用scanf读入string数据会出错,有博客说是scanf不支持C++所有的类

代码: 

#include <iostream>
#include<string>
#include<map>
using namespace std;

string unitDigit[13] = { "tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec" };
string tenDigit[13] = { "tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou" };
string numTostr[170];
map<string, int>strTonum;
void init()
{
	for (int i = 0; i < 13; i++)
	{
		numTostr[i] = unitDigit[i];
		strTonum[unitDigit[i]] = i;
		numTostr[i * 13] = tenDigit[i];
		strTonum[tenDigit[i]] = 13 * i;
	}

	for (int i = 1; i < 13; i++)//注意这里从十位为1开始,因为上面的for循环处理了个位数的情况
	{
		for (int j = 1; j < 13; j++)
		{
			string str = tenDigit[i]+ " " + unitDigit[j];
			numTostr[i * 13 + j] = str;
			strTonum[str] = i * 13 + j;
		}
	}
}


int main()
{
	init();
	int T;
	scanf("%d%*c", &T);
	while (T--)
	{
		string str;
		getline(cin, str);
		if (str[0] >= '0'&&str[0] <= '9')
		{
			int num = 0;
			for (int i = 0; i < str.length(); i++)
			{
				num = num * 10 + (str[i] - '0');
			}
			cout << numTostr[num] << endl;
		}
		else {
			cout << strTonum[str] << endl;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值