【Python】字典排序

【Python】字典排序

函数

sorted(iterable,key=None,reverse=False)

在这里插入图片描述

例题1

  1. 编程:统计下面文字(英文)中的单词数量,以及每个单词出现的次数。
    输入样例:
    failure is probably the fortification in your pole it is like a peek your wallet as the thief when you are thinking how to spend several hard-won lepta when you are wondering whether new money it has laid background because of you then at the heart of the most lax alert and most low awareness and left it godsend failed
    输出样例:
    单词总数是:46
    使用频率前五的单词:
    the=4
    it=3
    you=3
    and=2
    are=2
dict={}
words=''
st=input()
for i in st.split():
    if i not in dict.keys():
        dict[i]=1
    else:
        dict[i]+=1

dicts=list(dict.items())
dicts.sort(key=lambda x:(-x[1],x[0]))
print(len(dicts))
for i in range(5):
    if i>len(dicts):
        break
    key,values=dicts[i]
    print(f'{key}={values}')

例题2

现在需要统计若干段文字(英文)中的单词数量,并且还需统计每个单词出现的次数。

注1:单词之间以空格(1个或多个空格)为间隔。
注2:忽略空行或者空格行。

基本版:
统计时,区分字母大小写,且不删除指定标点符号。

进阶版:

统计前,需要从文字中删除指定标点符号!.,😗?。 注意:所谓的删除,就是用1个空格替换掉相应字符。
统计单词时需要忽略单词的大小写。
输入说明
若干行英文,最后以!!!为结束。

输出说明
单词数量
出现次数排名前10的单词(次数按照降序排序,如果次数相同,则按照键值的字母升序排序)及出现次数。

输入样例1
failure is probably the fortification in your pole

it is like a peek your wallet as the thief when you
are thinking how to spend several hard-won lepta

when you are wondering whether new money it has laid
background because of you then at the heart of the

most lax alert and most low awareness and left it

godsend failed
!!!

输出样例1
46
the=4
it=3
you=3
and=2
are=2
is=2
most=2
of=2
when=2
your=2

dict = {}
# 删除标点符号
while True:
    newstr = ''
    st = input()
    if st == "!!!!!":
        break
    for it in st:
        if it == '!' or it == '.' or it == ',' or it == ':' or it == '*' or it == '?':
            newstr += ' '
        else:
            newstr += it
 
 #统计单词个数
    st = newstr.lower()
    for it in st.split():
        if it not in dict.keys():
            dict[it] = 1
        else:
            dict[it] += 1
 
#排序
items = list(dict.items())
items.sort(key=lambda x:(-x[1],x[0]))
print(len(items))
for i in range(10):
    if i >= len(items):
        break
    key, val = items[i]
    print("{}={}".format(key, val))
 
  • 5
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值