1013 Digital Roots

Digital Roots

Digital Roots
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77179 Accepted Submission(s): 24120

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

代码

#include <iostream>
#include <string>

using namespace std;

int main()
{
    string n;
    while (cin >> n&&n != "0")
    {
        int sum = 0;
        for (int i = 0; i < n.length(); ++i)
            sum += n[i] - '0';
        cout << (sum - 1) % 9 + 1 << endl;
    }
    return 0;
}

瞅了几眼,习惯性的要直接开始写代码,在限定范围的时候,又感觉少了点什么,返回来看题,原来是没给范围。那就拿string写。之后在讨论区看到了更好的方法——九余数定理。
在度娘的帮助下(百度百科:弃九验算法→什么是弃九数)知道此题还有这么一种巧妙的做法,涨知识了

有了相关的知识储备后再来看代码, (sum - 1) % 9 + 1为什么要先 -1 再 +1 呢,因为直接 sum%9 会出现一个问题,那就是当 n=9 时,sum=9,得到的结果为0,显而易见答案是错误的。而先 -1 之后再 +1,对最终的结果是没有影响的,又避免了9本身作为除数时的尴尬


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值