10-排序6 Sort with Swap(0, i) [Java]

10-排序6 Sort with Swap(0, i))[Java]

Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
Each input file contains one test case, which gives a positive N (≤10
​5
​​ ) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9

import java.util.Scanner;

public class Main {
	private static int N;
	private static int[] A;
	private static int[] T;
	private static boolean[] visit; //记录是否访问过

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		N=sc.nextInt();
		A=new int[N];
		T=new int[N];
		visit=new boolean[N];
		for(int i=0;i<N;i++) {
			A[i]=sc.nextInt();
			visit[i]=false;  //初始化为都没有访问过
		}
		for(int i=0;i<N;i++) {
			T[A[i]]=i;
		}
		int S=0;  //单环个数
		int K=0;  //多环个数
		for(int i=0;i<N;i++) {   //计算环数不需要交换值,当回到访问过的节点即为环;
			if(visit[i]==false) {
				if(T[i]!=i) {
					visit[i]=true;
					int tmp=T[i];
					while(visit[tmp]==false) {
						visit[tmp]=true;
						tmp=T[tmp];
					}
					K++;
				}else if(T[i]==i) {
					S++;
					visit[i]=true;
				}
			}
		}
		if(S==N) {  //事先排好序的,不需要交换
			System.out.println(0);
		}
		else if(A[0]==0) {  //所有的环都不包含0
			System.out.println(N-S+K);
		}else {  //环中包含0
			System.out.println(N-S+K-2);
		}
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值